aboutsummaryrefslogtreecommitdiff
path: root/net/qt5-network
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-05-18 12:27:43 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-05-18 12:27:43 +0000
commit70141f1a3ab47238520955db870f6e9a5a5d4103 (patch)
tree783c9065a947687b97911fc572d2fd9079551afb /net/qt5-network
parent57824870548ec1b67b5b4691d7e9c16ca63ada69 (diff)
downloadports-70141f1a3ab47238520955db870f6e9a5a5d4103.tar.gz
ports-70141f1a3ab47238520955db870f6e9a5a5d4103.zip
Notes
Diffstat (limited to 'net/qt5-network')
-rw-r--r--net/qt5-network/Makefile1
-rw-r--r--net/qt5-network/files/patch-src_network_ssl_qsslcontext__opensslpre11.cpp (renamed from net/qt5-network/files/patch-src_network_ssl_qsslcontext__openssl.cpp)6
-rw-r--r--net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols.cpp69
-rw-r--r--net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h8
-rw-r--r--net/qt5-network/pkg-plist3
5 files changed, 40 insertions, 47 deletions
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index b0425a593ea4..4ddf24cf6b5a 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -2,7 +2,6 @@
PORTNAME= network
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 4
CATEGORIES= net ipv6
PKGNAMEPREFIX= qt5-
diff --git a/net/qt5-network/files/patch-src_network_ssl_qsslcontext__openssl.cpp b/net/qt5-network/files/patch-src_network_ssl_qsslcontext__opensslpre11.cpp
index a2ff4a92ca30..ca29c5e06f60 100644
--- a/net/qt5-network/files/patch-src_network_ssl_qsslcontext__openssl.cpp
+++ b/net/qt5-network/files/patch-src_network_ssl_qsslcontext__opensslpre11.cpp
@@ -2,9 +2,9 @@
* call the SSL_CTX_set1_groups function, which exists in LibreSSL as well as in
* OpenSSL and is what would be called through the macro
*
---- src/network/ssl/qsslcontext_openssl.cpp.orig 2018-01-16 06:53:43 UTC
-+++ src/network/ssl/qsslcontext_openssl.cpp
-@@ -354,12 +354,18 @@ init_context:
+--- src/network/ssl/qsslcontext_opensslpre11.cpp.orig 2017-11-30 13:49:46 UTC
++++ src/network/ssl/qsslcontext_opensslpre11.cpp
+@@ -332,12 +332,18 @@ init_context:
#if OPENSSL_VERSION_NUMBER >= 0x10002000L && !defined(OPENSSL_NO_EC)
// Set the curves to be used
if (q_SSLeay() >= 0x10002000L) {
diff --git a/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols.cpp b/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols.cpp
index d5e670f28183..e5608eded910 100644
--- a/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols.cpp
+++ b/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols.cpp
@@ -3,18 +3,9 @@
* Prepend the path of the SSL libraries used for building so the same libraries are
* found and loaded at runtime. Normal search finds base SSL libraries before ports.
*
---- src/network/ssl/qsslsocket_openssl_symbols.cpp.orig 2018-01-16 06:53:43 UTC
+--- src/network/ssl/qsslsocket_openssl_symbols.cpp.orig 2017-11-30 13:49:46 UTC
+++ src/network/ssl/qsslsocket_openssl_symbols.cpp
-@@ -151,7 +151,7 @@ DEFINEFUNC3(int, BIO_read, BIO *a, a, void *b, b, int
- DEFINEFUNC(BIO_METHOD *, BIO_s_mem, void, DUMMYARG, return 0, return)
- DEFINEFUNC3(int, BIO_write, BIO *a, a, const void *b, b, int c, c, return -1, return)
- DEFINEFUNC(int, BN_num_bits, const BIGNUM *a, a, return 0, return)
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if !defined(BN_is_word)
- DEFINEFUNC2(int, BN_is_word, BIGNUM *a, a, BN_ULONG w, w, return 0, return)
- #endif
- DEFINEFUNC2(BN_ULONG, BN_mod_word, const BIGNUM *a, a, BN_ULONG w, w, return static_cast<BN_ULONG>(-1), return)
-@@ -453,6 +453,9 @@ DEFINEFUNC(void, EC_KEY_free, EC_KEY *ecdh, ecdh, retu
+@@ -524,6 +524,9 @@ DEFINEFUNC(void, EC_KEY_free, EC_KEY *ecdh, ecdh, retu
DEFINEFUNC2(size_t, EC_get_builtin_curves, EC_builtin_curve * r, r, size_t nitems, nitems, return 0, return)
#if OPENSSL_VERSION_NUMBER >= 0x10002000L
DEFINEFUNC(int, EC_curve_nist2nid, const char *name, name, return 0, return)
@@ -24,7 +15,7 @@
#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
#endif // OPENSSL_NO_EC
-@@ -680,8 +683,8 @@ static QPair<QLibrary*, QLibrary*> loadO
+@@ -769,8 +772,8 @@ static QPair<QLibrary*, QLibrary*> loadOpenSsl()
#endif
#if defined(SHLIB_VERSION_NUMBER) && !defined(Q_OS_QNX) // on QNX, the libs are always libssl.so and libcrypto.so
// first attempt: the canonical name is libssl.so.<SHLIB_VERSION_NUMBER>
@@ -35,8 +26,8 @@
if (libcrypto->load() && libssl->load()) {
// libssl.so.<SHLIB_VERSION_NUMBER> and libcrypto.so.<SHLIB_VERSION_NUMBER> found
return pair;
-@@ -698,8 +701,8 @@ static QPair<QLibrary*, QLibrary*> loadO
- // OS X's /usr/lib/libssl.dylib, /usr/lib/libcrypto.dylib will be picked up in the third
+@@ -787,8 +790,8 @@ static QPair<QLibrary*, QLibrary*> loadOpenSsl()
+ // macOS's /usr/lib/libssl.dylib, /usr/lib/libcrypto.dylib will be picked up in the third
// attempt, _after_ <bundle>/Contents/Frameworks has been searched.
// iOS does not ship a system libssl.dylib, libcrypto.dylib in the first place.
- libssl->setFileNameAndVersion(QLatin1String("ssl"), -1);
@@ -46,18 +37,21 @@
if (libcrypto->load() && libssl->load()) {
// libssl.so.0 and libcrypto.so.0 found
return pair;
-@@ -790,7 +793,7 @@ bool q_resolveOpenSslSymbols()
- RESOLVEFUNC(EC_GROUP_get_degree)
- #endif
- RESOLVEFUNC(BN_num_bits)
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if !defined(BN_is_word)
- RESOLVEFUNC(BN_is_word)
- #endif
- RESOLVEFUNC(BN_mod_word)
-@@ -1020,8 +1023,12 @@ bool q_resolveOpenSslSymbols()
- RESOLVEFUNC(EC_KEY_free)
- RESOLVEFUNC(EC_get_builtin_curves)
+@@ -979,10 +982,9 @@ bool q_resolveOpenSslSymbols()
+ RESOLVEFUNC(OPENSSL_add_all_algorithms_conf)
+ RESOLVEFUNC(SSLeay)
+
+- if (!_q_SSLeay || q_SSLeay() >= 0x10100000L) {
++ if (!_q_SSLeay) {
+ // OpenSSL 1.1 has deprecated and removed SSLeay. We consider a failure to
+ // resolve this symbol as a failure to resolve symbols.
+- // The right operand of '||' above is ... a bit of paranoia.
+ delete libs.first;
+ delete libs.second;
+ qCWarning(lcSsl, "Incompatible version of OpenSSL");
+@@ -994,8 +996,12 @@ bool q_resolveOpenSslSymbols()
+
+ #ifndef OPENSSL_NO_EC
#if OPENSSL_VERSION_NUMBER >= 0x10002000L
- if (q_SSLeay() >= 0x10002000L)
+ if (q_SSLeay() >= 0x10002000L) {
@@ -65,19 +59,16 @@
+#if defined(LIBRESSL_VERSION_NUMBER)
+ RESOLVEFUNC(SSL_CTX_set1_groups)
+#endif // defined(LIBRESSL_VERSION_NUMBER)
-+ }
++ }
#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
#endif // OPENSSL_NO_EC
- RESOLVEFUNC(PKCS12_parse)
-@@ -1030,10 +1037,9 @@ bool q_resolveOpenSslSymbols()
- delete libs.first;
- delete libs.second;
-- if (!_q_SSLeay || q_SSLeay() >= 0x10100000L) {
-+ if (!_q_SSLeay) {
- // OpenSSL 1.1 deprecated and removed SSLeay. We consider a failure to
- // resolve this symbol as a failure to resolve symbols.
-- // The right operand of '||' above ... a bit of paranoia.
- qCWarning(lcSsl, "Incompatible version of OpenSSL");
- return false;
- }
+@@ -1017,7 +1023,7 @@ bool q_resolveOpenSslSymbols()
+ RESOLVEFUNC(EC_GROUP_get_degree)
+ #endif
+ RESOLVEFUNC(BN_num_bits)
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if !defined(BN_is_word)
+ RESOLVEFUNC(BN_is_word)
+ #endif
+ RESOLVEFUNC(BN_mod_word)
diff --git a/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h b/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h
index 4d204c734efe..23dc38628ee4 100644
--- a/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h
+++ b/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h
@@ -1,8 +1,8 @@
Boilerplate for SSL_CTX_set1_groups() used in qsslcontext_openssl.cpp.
---- src/network/ssl/qsslsocket_openssl_symbols_p.h.orig 2018-01-16 06:53:43 UTC
+--- src/network/ssl/qsslsocket_openssl_symbols_p.h.orig 2017-11-30 13:49:46 UTC
+++ src/network/ssl/qsslsocket_openssl_symbols_p.h
-@@ -228,7 +228,7 @@ int q_BIO_read(BIO *a, void *b, int c);
- Q_AUTOTEST_EXPORT BIO_METHOD *q_BIO_s_mem();
+@@ -232,7 +232,7 @@ BIO *q_BIO_new_mem_buf(void *a, int b);
+ int q_BIO_read(BIO *a, void *b, int c);
Q_AUTOTEST_EXPORT int q_BIO_write(BIO *a, const void *b, int c);
int q_BN_num_bits(const BIGNUM *a);
-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
@@ -10,7 +10,7 @@ Boilerplate for SSL_CTX_set1_groups() used in qsslcontext_openssl.cpp.
int q_BN_is_word(BIGNUM *a, BN_ULONG w);
#else
// BN_is_word is implemented purely as a
-@@ -511,6 +511,9 @@ void q_EC_KEY_free(EC_KEY *ecdh);
+@@ -454,6 +454,9 @@ void q_EC_KEY_free(EC_KEY *ecdh);
size_t q_EC_get_builtin_curves(EC_builtin_curve *r, size_t nitems);
#if OPENSSL_VERSION_NUMBER >= 0x10002000L
int q_EC_curve_nist2nid(const char *name);
diff --git a/net/qt5-network/pkg-plist b/net/qt5-network/pkg-plist
index a13a857479f4..17dc6ac15df2 100644
--- a/net/qt5-network/pkg-plist
+++ b/net/qt5-network/pkg-plist
@@ -18,6 +18,7 @@
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qhostaddress_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qhostinfo_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qhsts_p.h
+%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qhstsstore_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qhttp2protocolhandler_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qhttpmultipart_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qhttpnetworkconnection_p.h
@@ -71,8 +72,10 @@
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslkey_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslpresharedkeyauthenticator_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslsocket_mac_p.h
+%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslsocket_openssl11_symbols_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslsocket_openssl_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslsocket_openssl_symbols_p.h
+%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslsocket_opensslpre11_symbols_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslsocket_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qsslsocket_winrt_p.h
%%QT_INCDIR%%/QtNetwork/%%FULLVER%%/QtNetwork/private/qtcpserver_p.h