aboutsummaryrefslogtreecommitdiff
path: root/net/qtella/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2002-02-28 17:05:45 +0000
committerMikhail Teterin <mi@FreeBSD.org>2002-02-28 17:05:45 +0000
commit63381591a656297985122f896b2ac9f3ed9a0d44 (patch)
tree79c5cbecb937ba3c7bb941f2cc5b8bf8e2a260d6 /net/qtella/Makefile
parent7c48bcc6c7d3dc38ad31464acee3bb31e7ccfcad (diff)
Notes
Diffstat (limited to 'net/qtella/Makefile')
-rw-r--r--net/qtella/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/net/qtella/Makefile b/net/qtella/Makefile
index 059f301f9586..957408d3c4e9 100644
--- a/net/qtella/Makefile
+++ b/net/qtella/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qtella
-PORTVERSION= 0.2.1
+PORTVERSION= 0.4.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qtella
@@ -17,13 +17,12 @@ USE_KDELIBS_VER= 2
HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS+= --with-qt-dir=${X11BASE} --with-qt-moc=${X11BASE}/bin
+CONFIGURE_ENV+= LDFLAGS=-pthread CXXFLAGS="${CXXFLAGS} -pthread"
MAKE_ENV+= MOC=${X11BASE}/bin/moc2
+MAKE_ARGS+= -j2
pre-patch:
- @${PERL} -pi -e 's|stdint.h|inttypes.h|g' ${WRKSRC}/include/* ${WRKSRC}/src/Servent.cc \
- ${WRKSRC}/src/SearchViewItem.cc ${WRKSRC}/src/SharedViewItem.cc
-
-post-install:
- strip ${PREFIX}/bin/qtella
+ @${PERL} -pi.orig -e 's|/moc(\W)|/moc2\1|g' \
+ ${WRKSRC}/configure ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>