aboutsummaryrefslogtreecommitdiff
path: root/net/quagga/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-20 12:27:20 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-20 12:27:20 +0000
commit0a8d01d54b2d0bcb3313f1c7c4f9adb2e987ec1b (patch)
treeb5ae4ad1bb2b7ae2b381ce8d985ef85118f9198a /net/quagga/Makefile
parentb44f5f2242ce69dab8c5eb3574dee0131526c5e1 (diff)
downloadports-0a8d01d54b2d0bcb3313f1c7c4f9adb2e987ec1b.tar.gz
ports-0a8d01d54b2d0bcb3313f1c7c4f9adb2e987ec1b.zip
Notes
Diffstat (limited to 'net/quagga/Makefile')
-rw-r--r--net/quagga/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index ccb1762508e9..9207d4315650 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -3,6 +3,7 @@
PORTNAME= quagga
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= SAVANNAH
@@ -18,14 +19,16 @@ CONFLICTS= openbgpd-[0-9]* openospfd-[0-9]* zebra-0* quagga-re-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-exampledir=${PREFIX}/share/examples/quagga
INSTALL_TARGET= install-strip
-USES= gmake libtool makeinfo perl5 readline compiler:c11 autoreconf cpe
+USES= gmake libtool makeinfo perl5 readline compiler:c11 cpe
USE_LDCONFIG= yes
USE_PERL5= build
INFO= quagga
OPTIONS_DEFINE= ISISD PIMD PAM RTADV SNMP TCPSOCKETS DLMALLOC \
- NO_BGP_ANNOUNCE OSPF_NEXTHOP IRDP ISIS_TOPOLOGY
+ NO_BGP_ANNOUNCE OSPF_NEXTHOP ISIS_TOPOLOGY
+# IRDP needs something freebsd does not seem to have:
+# configure: error: 'IRDP requires in_pktinfo at the moment!'
OPTIONS_DEFAULT= ISISD PIMD RTADV
OPTIONS_SUB= yes
@@ -62,7 +65,7 @@ CONFIGURE_ARGS+=--enable-vty-group=${ENABLE_VTY_GROUP}
ISISD_CONFIGURE_ENABLE= isisd
ISIS_TOPOLOGY_CONFIGURE_ENABLE= isis-topology
PIMD_CONFIGURE_ENABLE= pimd
-IRDP_CONFIGURE_ENABLE= irdb
+IRDP_CONFIGURE_ENABLE= irdp
PAM_CONFIGURE_WITH= libpam
RTADV_CONFIGURE_ENABLE= rtadv
SNMP_CONFIGURE_ENABLE= snmp