aboutsummaryrefslogtreecommitdiff
path: root/net/quagga/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2007-10-01 10:54:10 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2007-10-01 10:54:10 +0000
commit197632b1eadd97640661c297cd0813f5ae712f5b (patch)
tree77db1bebaa826e0bdd00ece9395894c19a757e0f /net/quagga/Makefile
parent290d7664c7fd2513db9f42ec2663d960c85d80d7 (diff)
Notes
Diffstat (limited to 'net/quagga/Makefile')
-rw-r--r--net/quagga/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 03a01d074c29..cdc1ef4174fc 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,6 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.9
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
@@ -40,7 +41,7 @@ OPTIONS= ISISD "Enable experimental ISIS daemon" off \
SNMP "SNMP support" off \
TCPSOCKETS "Use TCP/IP sockets for protocol daemons" off \
TCPMD5 "Use experimental MD5 patch for BGP" off \
- DLMALLOC "Use dlmalloc (much faster)" off
+ DLMALLOC "Use dlmalloc (makes bgpd much faster)" off
.include <bsd.port.pre.mk>
@@ -120,6 +121,9 @@ CFLAGS+= -DQUAGGA_TCP_MD5SIG
.if defined(WITH_DLMALLOC)
LIB_DEPENDS+=dlmalloc.2:${PORTSDIR}/devel/libdlmalloc
LDFLAGS+=-ldlmalloc
+SUB_LIST= RCLDCONFIG=ldconfig
+.else
+SUB_LIST= RCLDCONFIG=
.endif
.if ${OSVERSION} < 600000
@@ -161,7 +165,7 @@ pre-everything::
@${ECHO} " WITH_SNMP SNMP support"
@${ECHO} " WITH_TCPSOCKETS Use TCP/IP sockets for protocol daemons"
@${ECHO} " WITH_TCPMD5 Use experimental MD5 patch for BGP"
- @${ECHO} " WITH_DLMALLOC Use dlmalloc (much faster)"
+ @${ECHO} " WITH_DLMALLOC Use dlmalloc (makes bgpd much faster)"
post-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL