aboutsummaryrefslogtreecommitdiff
path: root/net/quagga
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-02-15 22:17:36 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-02-15 22:17:36 +0000
commit6127f35649ebf53305fcbb7b4af90e96885047dd (patch)
treef2c25febe05f33dee3b23a4f54bdd1c48a441f58 /net/quagga
parent16b0ef895f2282cd50409edbcd5923866879046d (diff)
downloadports-6127f35649ebf53305fcbb7b4af90e96885047dd.tar.gz
ports-6127f35649ebf53305fcbb7b4af90e96885047dd.zip
Notes
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile6
-rw-r--r--net/quagga/distinfo6
-rw-r--r--net/quagga/files/patch-bgpd_bgp__aspath.c11
-rw-r--r--net/quagga/files/patch-bgpd_bgp__nht.c13
-rw-r--r--net/quagga/files/patch-configure12
-rw-r--r--net/quagga/files/patch-lib_command.c21
-rw-r--r--net/quagga/files/patch-vtysh_extract.pl.in4
-rw-r--r--net/quagga/pkg-plist2
8 files changed, 30 insertions, 45 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 29d7cb860220..1ab8bf88d134 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= quagga
-PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTVERSION= 1.2.3
CATEGORIES= net ipv6
MASTER_SITES= SAVANNAH
@@ -16,10 +15,11 @@ BUILD_DEPENDS= gawk:lang/gawk
CONFLICTS= openbgpd openospfd zebra quagga-esr frr pimd
+USES= compiler:c11 cpe gmake libtool makeinfo \
+ perl5 readline ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-exampledir=${PREFIX}/share/examples/quagga
INSTALL_TARGET= install-strip
-USES= gmake libtool makeinfo perl5 readline compiler:c11 cpe
USE_LDCONFIG= yes
USE_PERL5= build
diff --git a/net/quagga/distinfo b/net/quagga/distinfo
index 0b6813861ca8..456d8a8b1967 100644
--- a/net/quagga/distinfo
+++ b/net/quagga/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1507052274
-SHA256 (quagga-1.2.2.tar.gz) = 522e22f2beee64e3f0c2cde3d0155f3b8103f4f6fc8abef92cb40bc3a4cc2931
-SIZE (quagga-1.2.2.tar.gz) = 2986142
+TIMESTAMP = 1517952673
+SHA256 (quagga-1.2.3.tar.gz) = ee2c0907a106902abbdcaf63b4f28c67241c4f3396989ed54da7b4976eecad31
+SIZE (quagga-1.2.3.tar.gz) = 2925444
diff --git a/net/quagga/files/patch-bgpd_bgp__aspath.c b/net/quagga/files/patch-bgpd_bgp__aspath.c
deleted file mode 100644
index c31a71a54ba0..000000000000
--- a/net/quagga/files/patch-bgpd_bgp__aspath.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- bgpd/bgp_aspath.c.orig 2017-10-03 14:57:10 UTC
-+++ bgpd/bgp_aspath.c
-@@ -901,7 +901,7 @@ aspath_put (struct stream *s, struct aspath *as, int u
- while ( (seg->length - written) > AS_SEGMENT_MAX)
- {
- assegment_header_put (s, seg->type, AS_SEGMENT_MAX);
-- assegment_data_put (s, seg->as, AS_SEGMENT_MAX, use32bit);
-+ assegment_data_put (s, (seg->as+written), AS_SEGMENT_MAX, use32bit);
- written += AS_SEGMENT_MAX;
- bytes += ASSEGMENT_SIZE (AS_SEGMENT_MAX, use32bit);
- }
diff --git a/net/quagga/files/patch-bgpd_bgp__nht.c b/net/quagga/files/patch-bgpd_bgp__nht.c
deleted file mode 100644
index 7b0e6110de3d..000000000000
--- a/net/quagga/files/patch-bgpd_bgp__nht.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- bgpd/bgp_nht.c.orig 2017-10-03 16:57:10.000000000 +0200
-+++ bgpd/bgp_nht.c 2017-12-15 21:12:37.058505000 +0100
-@@ -409,8 +409,8 @@
- break;
- #ifdef HAVE_IPV6
- case AFI_IP6:
-- if (ri->attr->extra->mp_nexthop_len != 16
-- || IN6_IS_ADDR_LINKLOCAL (&ri->attr->extra->mp_nexthop_global))
-+ if (ri->attr->extra->mp_nexthop_len == 16
-+ && IN6_IS_ADDR_LINKLOCAL (&ri->attr->extra->mp_nexthop_global))
- return -1;
-
- p->family = AF_INET6;
diff --git a/net/quagga/files/patch-configure b/net/quagga/files/patch-configure
deleted file mode 100644
index 547b7de15c8f..000000000000
--- a/net/quagga/files/patch-configure
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.orig 2017-10-03 14:59:10 UTC
-+++ configure
-@@ -22070,7 +22070,7 @@ fi
- fi
-
-
-
--if test "${enable_snmp}" != ""; then
-+if test "x${enable_snmp}" != "xno"; then
- if test -n "$ac_tool_prefix"; then
- # Extract the first word of "${ac_tool_prefix}net-snmp-config", so it can be a program name with args.
- set dummy ${ac_tool_prefix}net-snmp-config; ac_word=$2
diff --git a/net/quagga/files/patch-lib_command.c b/net/quagga/files/patch-lib_command.c
new file mode 100644
index 000000000000..d8600803a056
--- /dev/null
+++ b/net/quagga/files/patch-lib_command.c
@@ -0,0 +1,21 @@
+--- lib/command.c.orig 2018-02-04 17:34:34 UTC
++++ lib/command.c
+@@ -3127,15 +3127,15 @@ DEFUN (config_write_file,
+
+ if ((dupfd = dup (file_vty->wfd)) < 0)
+ {
+- vty_out (vty, "Couldn't dup fd (for fdatasync) for %s, %s (%d).%s",
++ vty_out (vty, "Couldn't dup fd (for fsync) for %s, %s (%d).%s",
+ config_file, safe_strerror(errno), errno, VTY_NEWLINE);
+ }
+
+ vty_close (file_vty);
+
+- if (fdatasync (dupfd) < 0)
++ if (fsync (dupfd) < 0)
+ {
+- vty_out (vty, "Couldn't fdatasync %s, %s (%d)!%s",
++ vty_out (vty, "Couldn't fsync %s, %s (%d)!%s",
+ config_file, safe_strerror(errno), errno, VTY_NEWLINE);
+ }
+
diff --git a/net/quagga/files/patch-vtysh_extract.pl.in b/net/quagga/files/patch-vtysh_extract.pl.in
index 44ddef59d4f5..36e93abda745 100644
--- a/net/quagga/files/patch-vtysh_extract.pl.in
+++ b/net/quagga/files/patch-vtysh_extract.pl.in
@@ -1,6 +1,6 @@
---- vtysh/extract.pl.in.orig 2016-10-18 13:03:52 UTC
+--- vtysh/extract.pl.in.orig 2018-02-04 17:34:34 UTC
+++ vtysh/extract.pl.in
-@@ -69,7 +69,7 @@ my $cli_stomp = 0;
+@@ -75,7 +75,7 @@ my $cli_stomp = 0;
foreach (@ARGV) {
$file = $_;
diff --git a/net/quagga/pkg-plist b/net/quagga/pkg-plist
index cb8a9ef0c4a5..bec6e377a2a3 100644
--- a/net/quagga/pkg-plist
+++ b/net/quagga/pkg-plist
@@ -100,7 +100,7 @@ sbin/zebra
%%ISISD%%%%EXAMPLESDIR%%/isisd.conf.sample
%%EXAMPLESDIR%%/ospf6d.conf.sample
%%EXAMPLESDIR%%/ospfd.conf.sample
-%%PIMD%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pimd.conf.sample
+%%PIMD%%%%EXAMPLESDIR%%/pimd.conf.sample
%%EXAMPLESDIR%%/ripd.conf.sample
%%EXAMPLESDIR%%/ripngd.conf.sample
%%EXAMPLESDIR%%/vtysh.conf.sample