aboutsummaryrefslogtreecommitdiff
path: root/net/quagga
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-31 03:03:15 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-31 03:03:15 +0000
commit64f2a45295f5cba6a9bb816b4b8f4c62a14da35d (patch)
tree26288be76d54b917dc6ade5e04a74fc75325ef75 /net/quagga
parent9be7699cb5d7505ca5cad090e0c717bd24179959 (diff)
downloadports-64f2a45295f5cba6a9bb816b4b8f4c62a14da35d.tar.gz
ports-64f2a45295f5cba6a9bb816b4b8f4c62a14da35d.zip
Notes
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile14
-rw-r--r--net/quagga/distinfo6
-rw-r--r--net/quagga/files/patch-memory.c11
-rw-r--r--net/quagga/files/patch-zebra-connected.c48
-rw-r--r--net/quagga/pkg-plist1
5 files changed, 13 insertions, 67 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 599986eb53a2..0fcf7013abd1 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= quagga
-PORTVERSION= 0.99.4
-PORTREVISION= 2
+PORTVERSION= 0.99.5
CATEGORIES= net ipv6
-MASTER_SITES= http://quagga.net/download/
+MASTER_SITES= http://quagga.net/download/ \
+ http://www.ru.quagga.net/download/ \
+ http://www.de.quagga.net/download/ \
+ http://www.us.quagga.net/download/ \
+ http://www.us2.quagga.net/download/ \
+ http://www.au.quagga.net/download/
PATCH_SITES= http://quagga.net/
MAINTAINER= boris@tagnet.ru
COMMENT= Free RIPv1, RIPv2, OSPFv2, BGP4, IS-IS route software
-CONFLICTS= openbgpd-* zebra-0*
+CONFLICTS= openbgpd-[0-9]* zebra-0*
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_PERL5_BUILD= yes
LIBTOOLFILES= configure
diff --git a/net/quagga/distinfo b/net/quagga/distinfo
index e54b282131e9..90f505e5fa4f 100644
--- a/net/quagga/distinfo
+++ b/net/quagga/distinfo
@@ -1,3 +1,3 @@
-MD5 (quagga-0.99.4.tar.gz) = a75d3f5ed0b3354274c28d195e3f6479
-SHA256 (quagga-0.99.4.tar.gz) = 4044bfacb44ec9fa9160b56aeb1e76e1ca62b17115ae38298065cbaad16491a7
-SIZE (quagga-0.99.4.tar.gz) = 2207774
+MD5 (quagga-0.99.5.tar.gz) = 3f9c71aca6faa22a889e2f84ecfd0076
+SHA256 (quagga-0.99.5.tar.gz) = 2555535654893806d21e804406f2cf594214bb2b9661458eb5bbf00402c31c7b
+SIZE (quagga-0.99.5.tar.gz) = 2311140
diff --git a/net/quagga/files/patch-memory.c b/net/quagga/files/patch-memory.c
deleted file mode 100644
index d8e37bf8e648..000000000000
--- a/net/quagga/files/patch-memory.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/memory.c.orig Thu Mar 30 19:47:38 2006
-+++ lib/memory.c Thu May 11 10:18:36 2006
-@@ -21,7 +21,7 @@
- */
-
- #include <zebra.h>
--#include <malloc.h>
-+#include <stdlib.h>
-
- #include "log.h"
- #include "memory.h"
diff --git a/net/quagga/files/patch-zebra-connected.c b/net/quagga/files/patch-zebra-connected.c
deleted file mode 100644
index 7742cc8e0d8f..000000000000
--- a/net/quagga/files/patch-zebra-connected.c
+++ /dev/null
@@ -1,48 +0,0 @@
---- zebra/connected.c.orig Mon May 22 11:48:55 2006
-+++ zebra/connected.c Mon May 22 11:49:48 2006
-@@ -60,8 +60,11 @@
- UNSET_FLAG (ifc->conf, ZEBRA_IFC_REAL);
- }
-
-- listnode_delete (ifc->ifp->connected, ifc);
-- connected_free (ifc);
-+ if (!CHECK_FLAG (ifc->conf, ZEBRA_IFC_CONFIGURED))
-+ {
-+ listnode_delete (ifc->ifp->connected, ifc);
-+ connected_free (ifc);
-+ }
- }
-
- static void
-@@ -225,7 +228,14 @@
-
- /* Check same connected route. */
- if ((current = connected_check (ifp, (struct prefix *) ifc->address)))
-- connected_withdraw (current); /* implicit withdraw - freebsd does this */
-+ {
-+ if (CHECK_FLAG(current->conf, ZEBRA_IFC_CONFIGURED))
-+ {
-+ SET_FLAG(ifc->conf, ZEBRA_IFC_CONFIGURED);
-+ UNSET_FLAG(current->conf, ZEBRA_IFC_CONFIGURED);
-+ }
-+ connected_withdraw (current); /* implicit withdraw - freebsd does this */
-+ }
-
- connected_announce (ifp, ifc);
- }
-@@ -364,7 +374,14 @@
- ifc->label = XSTRDUP (MTYPE_CONNECTED_LABEL, label);
-
- if ((current = connected_check (ifp, (struct prefix *) ifc->address)))
-- connected_withdraw (current); /* implicit update of existing address */
-+ {
-+ if (CHECK_FLAG(current->conf, ZEBRA_IFC_CONFIGURED))
-+ {
-+ SET_FLAG(ifc->conf, ZEBRA_IFC_CONFIGURED);
-+ UNSET_FLAG(current->conf, ZEBRA_IFC_CONFIGURED);
-+ }
-+ connected_withdraw (current); /* implicit update of existing address */
-+ }
-
- connected_announce (ifp, ifc);
- }
diff --git a/net/quagga/pkg-plist b/net/quagga/pkg-plist
index 8b0dc72cffaf..da4cf1081b36 100644
--- a/net/quagga/pkg-plist
+++ b/net/quagga/pkg-plist
@@ -52,6 +52,7 @@ include/quagga/pqueue.h
include/quagga/prefix.h
include/quagga/privs.h
include/quagga/routemap.h
+include/quagga/route_types.h
include/quagga/sigevent.h
include/quagga/smux.h
include/quagga/sockopt.h