aboutsummaryrefslogtreecommitdiff
path: root/net/quagga
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2019-07-06 14:08:35 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2019-07-06 14:08:35 +0000
commita5545926197a0f5d05876d021306a955802813c9 (patch)
treeb9511d1d119bf3fe05284f564f04611b3c6cc1de /net/quagga
parent91f1d2798aceb0c46243b212c2393a0dff8fd550 (diff)
Notes
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/patch-lib_thread.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index d24254993362..5284fdf76fa6 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quagga
PORTVERSION= 1.2.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net ipv6
MASTER_SITES= SAVANNAH
diff --git a/net/quagga/files/patch-lib_thread.c b/net/quagga/files/patch-lib_thread.c
new file mode 100644
index 000000000000..fdfe14662332
--- /dev/null
+++ b/net/quagga/files/patch-lib_thread.c
@@ -0,0 +1,11 @@
+--- lib/thread.c.orig 2018-02-19 21:24:55 UTC
++++ lib/thread.c
+@@ -603,6 +603,8 @@ thread_add_fd (struct thread **thread_ar
+ static void
+ thread_add_unuse (struct thread *thread)
+ {
++ if (thread->type == THREAD_UNUSED)
++ return;
+ thread->type = THREAD_UNUSED;
+ assert (thread->master != NULL && thread != NULL);
+ assert (thread->next == NULL);