aboutsummaryrefslogtreecommitdiff
path: root/net/quagga
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2010-10-21 14:03:23 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2010-10-21 14:03:23 +0000
commit77b52d4908fa221c9e8c5039be834587a7c2f794 (patch)
treed01614ab3868d3e23dcbf364c7583122f62ce5bc /net/quagga
parent0708494d521b548dec30655e2658be65ec1ce555 (diff)
downloadports-77b52d4908fa221c9e8c5039be834587a7c2f794.tar.gz
ports-77b52d4908fa221c9e8c5039be834587a7c2f794.zip
Notes
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/patch-git-114
2 files changed, 15 insertions, 1 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 9e3212ed1e56..ab64de39830a 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/patch-git-1 b/net/quagga/files/patch-git-1
new file mode 100644
index 000000000000..0de3b0b0235e
--- /dev/null
+++ b/net/quagga/files/patch-git-1
@@ -0,0 +1,14 @@
+diff --git bgpd/bgp_route.c bgpd/bgp_route.c
+index 2391f74..1cfc451 100644
+--- bgpd/bgp_route.c
++++ bgpd/bgp_route.c
+@@ -6145,7 +6145,8 @@ route_vty_out_detail (struct vty *vty, struct bgp *bgp, struct prefix *p,
+ bgp_damp_info_vty (vty, binfo);
+
+ /* Line 7 display Uptime */
+- vty_out (vty, " Last update: %s", ctime (&binfo->uptime));
++ time_t tbuf = time(NULL) - (bgp_clock() - binfo->uptime);
++ vty_out (vty, " Last update: %s", ctime(&tbuf));
+ }
+ vty_out (vty, "%s", VTY_NEWLINE);
+ }