aboutsummaryrefslogtreecommitdiff
path: root/net/quagga
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-02-10 12:45:36 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-02-10 12:45:36 +0000
commit8558006a0ab49b6b664d99161a6379121cbc1026 (patch)
tree04adf06d92d4832e055d4812d9847aee8cae9965 /net/quagga
parentfa0f5bbf794013baccd505eda42fdc60e987b0b8 (diff)
downloadports-8558006a0ab49b6b664d99161a6379121cbc1026.tar.gz
ports-8558006a0ab49b6b664d99161a6379121cbc1026.zip
Notes
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile6
-rw-r--r--net/quagga/files/patch-lib-buffer.c2
-rw-r--r--net/quagga/files/patch-ospfd-ospf_api.c11
3 files changed, 15 insertions, 4 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 12dc4332d035..a6735984e9d7 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/
@@ -120,9 +120,9 @@ CONFIGURE_ARGS+=--enable-rtadv
.if defined(WITH_SNMP) && !defined(WITHOUT_SNMP)
CONFIGURE_ARGS+=--enable-snmp
.if defined(WITH_SNMP_4)
-LIB_DEPENDS+=snmp.4:${PORTSDIR}/net-mgmt/net-snmp4:install
+LIB_DEPENDS+=snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
.else
-LIB_DEPENDS+=netsnmp.9:${PORTSDIR}/net-mgmt/net-snmp:install
+LIB_DEPENDS+=netsnmp.9:${PORTSDIR}/net-mgmt/net-snmp
.endif
.endif
diff --git a/net/quagga/files/patch-lib-buffer.c b/net/quagga/files/patch-lib-buffer.c
index 61fda3c21d71..0aba361550bb 100644
--- a/net/quagga/files/patch-lib-buffer.c
+++ b/net/quagga/files/patch-lib-buffer.c
@@ -5,7 +5,7 @@
/* Actual data stream (variable length). */
- unsigned char data[]; /* real dimension is buffer->size */
-+ unsigned char *data; /* real dimension is buffer->size */
++ unsigned char data[0]; /* real dimension is buffer->size */
};
/* It should always be true that: 0 <= sp <= cp <= size */
diff --git a/net/quagga/files/patch-ospfd-ospf_api.c b/net/quagga/files/patch-ospfd-ospf_api.c
new file mode 100644
index 000000000000..e641ce884d1e
--- /dev/null
+++ b/net/quagga/files/patch-ospfd-ospf_api.c
@@ -0,0 +1,11 @@
+--- ospfd/ospf_api.c.orig Thu Nov 24 21:51:16 2005
++++ ospfd/ospf_api.c Wed Feb 8 11:49:31 2006
+@@ -68,7 +68,7 @@
+ struct opaque_lsa
+ {
+ struct lsa_header header;
+- u_char mydata[];
++ u_char mydata[0];
+ };
+
+ struct opaque_lsa *olsa;