aboutsummaryrefslogtreecommitdiff
path: root/net/quoted
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-06-05 21:56:53 +0000
committerSimon Barner <barner@FreeBSD.org>2005-06-05 21:56:53 +0000
commit73b0a29142a62ac83b066b249323147d9b3bb502 (patch)
treec94c05149690218c5d90604b55675887629d7579 /net/quoted
parent65fd7be552d047065aa5c1dfb9b1a1529ff1f3f4 (diff)
downloadports-73b0a29142a62ac83b066b249323147d9b3bb502.tar.gz
ports-73b0a29142a62ac83b066b249323147d9b3bb502.zip
Notes
Diffstat (limited to 'net/quoted')
-rw-r--r--net/quoted/Makefile28
-rw-r--r--net/quoted/distinfo2
-rw-r--r--net/quoted/files/patch-quoted.sh.rc.freebsd20
-rw-r--r--net/quoted/pkg-descr11
-rw-r--r--net/quoted/pkg-plist5
5 files changed, 66 insertions, 0 deletions
diff --git a/net/quoted/Makefile b/net/quoted/Makefile
new file mode 100644
index 000000000000..a8445c53d8c9
--- /dev/null
+++ b/net/quoted/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: quoted
+# Date created: 1 December 2004
+# Whom: Bob Frazier
+#
+# $FreeBSD$
+#
+
+PORTNAME= quoted
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.mrp3.com/webutil/
+
+MAINTAINER= bobf@mrp3.com
+COMMENT= Easily configured QOTD daemon with over 130 good quality quotes
+
+MAN1= quoted.1
+MANCOMPRESSED= no
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+USE_RC_SUBR= yes
+RC_SUFX= .sh
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/local,${PREFIX},g; s,/etc/rc.subr,${RC_SUBR},g;" ${WRKSRC}/quoted.sh.rc.freebsd
+
+.include <bsd.port.mk>
diff --git a/net/quoted/distinfo b/net/quoted/distinfo
new file mode 100644
index 000000000000..2e2af88e4f23
--- /dev/null
+++ b/net/quoted/distinfo
@@ -0,0 +1,2 @@
+MD5 (quoted-1.0.tar.gz) = 75d0a97140786a1b19587589e6782528
+SIZE (quoted-1.0.tar.gz) = 121047
diff --git a/net/quoted/files/patch-quoted.sh.rc.freebsd b/net/quoted/files/patch-quoted.sh.rc.freebsd
new file mode 100644
index 000000000000..662491ea6b37
--- /dev/null
+++ b/net/quoted/files/patch-quoted.sh.rc.freebsd
@@ -0,0 +1,20 @@
+--- quoted.sh.rc.freebsd.orig Thu Dec 2 02:20:30 2004
++++ quoted.sh.rc.freebsd Wed Jun 1 14:34:54 2005
+@@ -16,7 +16,7 @@
+ name="quoted"
+ rcvar=`set_rcvar`
+ command="${dir}/${name}"
+-command_args="-d"
++command_args="-d -p:17"
+ command_plus_args="${command} ${command_args}"
+ pidfile="/var/run/${name}.pid"
+ required_files="${etc}/quotes"
+@@ -31,7 +31,7 @@
+ if [ -e ${required_files} ] ; then
+ ${command_plus_args}
+ sleep 1
+- pid=`ps -aewx -o "pid,command" | grep -- "${command_plus_args}" | grep -v "grep" | awk '{ print \$1; }'`
++ pid=`ps ax | awk '{if (match($5, ".*/quoted$") || $5 == "quoted") print $1}`
+ if [ -z ${pid} ]; then
+ echo "${name} failed to start"
+ return 1
diff --git a/net/quoted/pkg-descr b/net/quoted/pkg-descr
new file mode 100644
index 000000000000..53e02a7481db
--- /dev/null
+++ b/net/quoted/pkg-descr
@@ -0,0 +1,11 @@
+quoted - QOTD Daemon
+
+The QOTD Daemon 'quoted' listens on the qotd port (17) and responds with
+a randomly selected 'quote of the day' from a 'quotes' text file, which
+you can update with quotes of your own. It will operate either as a
+stand-alone daemon, or can also be invoked via inetd.
+
+If you want, you can also have it listen on a different port, other than
+the default 'qotd' port (17).
+
+WWW: http://www.mrp3.com/webutil/quoted.html
diff --git a/net/quoted/pkg-plist b/net/quoted/pkg-plist
new file mode 100644
index 000000000000..8219cfea32c5
--- /dev/null
+++ b/net/quoted/pkg-plist
@@ -0,0 +1,5 @@
+@unexec %D/etc/rc.d/quoted.sh stop 2>/dev/null > /dev/null || true
+@unexec rm -f /var/run/quoted.pid
+bin/quoted
+etc/quotes
+etc/rc.d/quoted.sh