aboutsummaryrefslogtreecommitdiff
path: root/net/rabbitmq-c-devel/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-14 12:44:23 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-14 12:44:23 +0000
commitc95e044e44f736c6d87a2b7891e72ef2d0317494 (patch)
tree11de05dc3a3d5ccd41888382760240b69c920063 /net/rabbitmq-c-devel/Makefile
parenteb4a56de2fb443128164d86249a66a31d5af6e76 (diff)
downloadports-c95e044e44f736c6d87a2b7891e72ef2d0317494.tar.gz
ports-c95e044e44f736c6d87a2b7891e72ef2d0317494.zip
Notes
Diffstat (limited to 'net/rabbitmq-c-devel/Makefile')
-rw-r--r--net/rabbitmq-c-devel/Makefile18
1 files changed, 3 insertions, 15 deletions
diff --git a/net/rabbitmq-c-devel/Makefile b/net/rabbitmq-c-devel/Makefile
index f3168360e60d..26f65c4cc77f 100644
--- a/net/rabbitmq-c-devel/Makefile
+++ b/net/rabbitmq-c-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rabbitmq-c
PORTVERSION= 0.5.1
+PORTREVISION= 1
CATEGORIES= net
PKGNAMESUFFIX= -devel
@@ -17,25 +18,18 @@ BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
CONFLICTS= rabbitmq-c-[0-9]*
-USES= cmake tar:bzip2 libtool python
+USES= cmake python tar:bzip2
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= alanxz
GH_COMMIT= e554ca7
GH_TAGNAME= v${PORTVERSION}
-OPTIONS_DEFINE= 64BIT POPT
-64BIT_DESC= Produce 64-bit library
+OPTIONS_DEFINE= POPT
POPT_DESC= Popt support in tools
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:M64BIT}
-ONLY_FOR_ARCHS= amd64 sparc64 powerpc
-ONLY_FOR_ARCHS_REASON= 64BIT option is set
-CONFIGURE_ARGS+= --enable-64-bit
-.endif
-
.if ${PORT_OPTIONS:MPOPT}
LIB_DEPENDS+= libpopt.so:${PORTSDIR}/devel/popt
CFLAGS+= -I${LOCALBASE}/include
@@ -45,12 +39,6 @@ PLIST_SUB+= POPT=""
PLIST_SUB+= POPT="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|rabbitmq-codegen|rabbitmq-codegen-df43f2bfcf0e|g' ${WRKSRC}/configure.ac
-
-pre-configure:
- @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE})
-
post-stage:
${MV} ${STAGEDIR}${PREFIX}/lib/pkgconfig/librabbitmq.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/librabbitmq.pc
${RMDIR} ${STAGEDIR}${PREFIX}/lib/pkgconfig