aboutsummaryrefslogtreecommitdiff
path: root/net/radius
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-12-11 02:36:19 +0000
committerSteve Price <steve@FreeBSD.org>2000-12-11 02:36:19 +0000
commitb0642e71ddf92e1084aa73ad9f31875d65daf302 (patch)
tree93c66c9510c0f4a329e2ea04e2d8fffee6e68d7d /net/radius
parent2fca6090bb5ec258b2e25a6a44b1aa3017b38e5c (diff)
downloadports-b0642e71ddf92e1084aa73ad9f31875d65daf302.tar.gz
ports-b0642e71ddf92e1084aa73ad9f31875d65daf302.zip
Notes
Diffstat (limited to 'net/radius')
-rw-r--r--net/radius/Makefile1
-rw-r--r--net/radius/files/patch-ab13
2 files changed, 12 insertions, 2 deletions
diff --git a/net/radius/Makefile b/net/radius/Makefile
index cdccdc8fb907..5e336209a0fb 100644
--- a/net/radius/Makefile
+++ b/net/radius/Makefile
@@ -7,6 +7,7 @@
PORTNAME= radius-basic
PORTVERSION= 3.6B
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.merit.edu/radius/releases/
DISTNAME= radius.3.6B.basic
diff --git a/net/radius/files/patch-ab b/net/radius/files/patch-ab
index 8254dfa5cc69..f466a5bc7003 100644
--- a/net/radius/files/patch-ab
+++ b/net/radius/files/patch-ab
@@ -1,5 +1,5 @@
---- src/radiusd.c~ Mon Jul 27 22:52:37 1998
-+++ src/radiusd.c Thu Sep 17 18:31:50 1998
+--- src/radiusd.c.orig Mon Jul 27 15:52:37 1998
++++ src/radiusd.c Sun Dec 10 17:04:17 2000
@@ -793,6 +793,19 @@
sigaction (SIGIOT, &action, NULL); /* Perhaps also known as SIGABRT ! */
sigaction (SIGFPE, &action, NULL);
@@ -28,3 +28,12 @@
for (j = dtablesize; j >= 3; j--)
{
+@@ -4467,7 +4481,7 @@
+ while ((event = authreq->event_q) != (EVENT_ENT *) NULL)
+ {
+ authreq->event_q = event->next;
+- free_event_final (event);
++ free_event (event);
+ }
+
+ while ((event = authreq->freed_events) != (EVENT_ENT *) NULL)