aboutsummaryrefslogtreecommitdiff
path: root/net/rclone
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-13 14:58:08 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-13 14:58:08 +0000
commitc4cc383eb91d181cfd792d42cb98114ff0cf025c (patch)
treeb37028dd2b3f9dcbc4488d55b683b15945c46ee8 /net/rclone
parentc7ce233cc9f4c95c554d5c8f3de1db225d6ff71a (diff)
downloadports-c4cc383eb91d181cfd792d42cb98114ff0cf025c.tar.gz
ports-c4cc383eb91d181cfd792d42cb98114ff0cf025c.zip
Notes
Diffstat (limited to 'net/rclone')
-rw-r--r--net/rclone/Makefile100
1 files changed, 27 insertions, 73 deletions
diff --git a/net/rclone/Makefile b/net/rclone/Makefile
index 951069184a30..a01104b7908e 100644
--- a/net/rclone/Makefile
+++ b/net/rclone/Makefile
@@ -12,87 +12,41 @@ LICENSE= MIT
USES= go
USE_GITHUB= yes
+GH_ACCOUNT= ncw
+GH_SUBDIR= src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}
GH_TUPLE+= \
- ncw:rclone:${DISTVERSIONFULL} \
- ncw:go-acd:56da839:goacd \
- ncw:swift:b964f2c:swift \
- aws:aws-sdk-go:87a2cff:awssdkgo \
- mreiferson:go-httpclient:31f0106:gohttpclient \
- google:go-querystring:9235644:goquerystring \
- GoogleCloudPlatform:google-cloud-go:80a7732:gcloudgolang \
- google:google-api-go-client:0caa379:googleapigoclient \
- golang:oauth2:3c3a985:oauth2 \
- golang:net:6d3beae:net \
- golang:text:a7c0236:text \
- skratchdot:open-golang:75fb7ed:opengolang \
- stacktic:dropbox:58f839b:dropbox \
- tsenart:tb:19f4c3d:tb \
- VividCortex:ewma:c595cd8:ewma \
- golang:crypto:8e06e8d:crypto \
- pkg:errors:a887431:errors \
- bazil:fuse:371fbbd:fuse \
- spf13:cobra:9c28e4b:cobra \
- spf13:pflag:c7e63cf:pflag \
- rfjakob:eme:601d0e2:eme \
- ogier:pflag:45c278a:opflag \
- Unknwon:goconfig:5aa4f8c:goconfig \
- cpuguy83:go-md2man:a65d4d2:gomd2man
+ google:google-api-go-client:0caa379:googleapigoclient/src/google.golang.org/api \
+ ncw:go-acd:56da839:goacd/src/github.com/ncw/go-acd \
+ ncw:swift:b964f2c:swift/src/github.com/ncw/swift \
+ aws:aws-sdk-go:87a2cff:awssdkgo/src/github.com/aws/aws-sdk-go \
+ mreiferson:go-httpclient:31f0106:gohttpclient/src/github.com/mreiferson/go-httpclient \
+ google:go-querystring:9235644:goquerystring/src/github.com/google/go-querystring \
+ GoogleCloudPlatform:google-cloud-go:80a7732:gcloudgolang/src/cloud.google.com/go \
+ golang:oauth2:3c3a985:oauth2/src/golang.org/x/oauth2 \
+ golang:net:6d3beae:net/src/golang.org/x/net \
+ golang:text:a7c0236:text/src/golang.org/x/text \
+ skratchdot:open-golang:75fb7ed:opengolang/src/github.com/skratchdot/open-golang \
+ stacktic:dropbox:58f839b:dropbox/src/github.com/stacktic/dropbox \
+ tsenart:tb:19f4c3d:tb/src/github.com/tsenart/tb \
+ VividCortex:ewma:c595cd8:ewma/src/github.com/VividCortex/ewma \
+ golang:crypto:8e06e8d:crypto/src/golang.org/x/crypto \
+ pkg:errors:a887431:errors/src/github.com/pkg/errors \
+ bazil:fuse:371fbbd:fuse/src/bazil.org/fuse \
+ spf13:cobra:9c28e4b:cobra/src/github.com/spf13/cobra \
+ spf13:pflag:c7e63cf:pflag/src/github.com/spf13/pflag \
+ rfjakob:eme:601d0e2:eme/src/github.com/rfjakob/eme \
+ ogier:pflag:45c278a:opflag/src/github.com/ogier/pflag \
+ Unknwon:goconfig:5aa4f8c:goconfig/src/github.com/Unknwon/goconfig \
+ cpuguy83:go-md2man:a65d4d2:gomd2man/src/github.com/cpuguy83/go-md2man
PLIST_FILES= bin/rclone
STRIP= # stripping can break go binaries
-post-extract:
- @${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
-.for src in amazonclouddrive b2 cmd crypt dircache docs drive dropbox fs fstest googlecloudstorage graphics hubic local oauthutil onedrive pacer rest s3 swift yandex CONTRIBUTING.md COPYING README.md appveyor.yml rclone.go
- @${MV} ${WRKSRC}/${src} \
- ${WRKSRC}/src/github.com/ncw/${PORTNAME}
-.endfor
- @${MKDIR} ${WRKSRC}/src/bazil.org
- @${MKDIR} ${WRKSRC}/src/github.com/Unknwon
- @${MKDIR} ${WRKSRC}/src/github.com/cpuguy83
- @${MKDIR} ${WRKSRC}/src/github.com/ogier
- @${MKDIR} ${WRKSRC}/src/github.com/rfjakob
- @${MKDIR} ${WRKSRC}/src/github.com/spf13
- @${MKDIR} ${WRKSRC}/src/github.com/stacktic
- @${MKDIR} ${WRKSRC}/src/github.com/tsenart
- @${MKDIR} ${WRKSRC}/src/github.com/VividCortex
- @${MKDIR} ${WRKSRC}/src/github.com/aws
- @${MKDIR} ${WRKSRC}/src/github.com/mreiferson
- @${MKDIR} ${WRKSRC}/src/github.com/skratchdot
- @${MKDIR} ${WRKSRC}/src/github.com/google
- @${MKDIR} ${WRKSRC}/src/github.com/pkg
- @${MKDIR} ${WRKSRC}/src/golang.org/x
- @${MKDIR} ${WRKSRC}/src/cloud.google.com
- @${MKDIR} ${WRKSRC}/src/google.golang.org
- @${MV} ${WRKSRC_fuse} ${WRKSRC}/src/bazil.org/fuse
- @${MV} ${WRKSRC_swift} ${WRKSRC}/src/github.com/ncw/swift
- @${MV} ${WRKSRC_goacd} ${WRKSRC}/src/github.com/ncw/go-acd
- @${MV} ${WRKSRC_goconfig} ${WRKSRC}/src/github.com/Unknwon/goconfig
- @${MV} ${WRKSRC_gomd2man} ${WRKSRC}/src/github.com/cpuguy83/go-md2man
- @${MV} ${WRKSRC_opflag} ${WRKSRC}/src/github.com/ogier/pflag
- @${MV} ${WRKSRC_eme} ${WRKSRC}/src/github.com/rfjakob/eme
- @${MV} ${WRKSRC_cobra} ${WRKSRC}/src/github.com/spf13/cobra
- @${MV} ${WRKSRC_pflag} ${WRKSRC}/src/github.com/spf13/pflag
- @${MV} ${WRKSRC_dropbox} ${WRKSRC}/src/github.com/stacktic/dropbox
- @${MV} ${WRKSRC_tb} ${WRKSRC}/src/github.com/tsenart/tb
- @${MV} ${WRKSRC_ewma} ${WRKSRC}/src/github.com/VividCortex/ewma
- @${MV} ${WRKSRC_awssdkgo} ${WRKSRC}/src/github.com/aws/aws-sdk-go
- @${MV} ${WRKSRC_gohttpclient} ${WRKSRC}/src/github.com/mreiferson/go-httpclient
- @${MV} ${WRKSRC_opengolang} ${WRKSRC}/src/github.com/skratchdot/open-golang
- @${MV} ${WRKSRC_goquerystring} ${WRKSRC}/src/github.com/google/go-querystring
- @${MV} ${WRKSRC_errors} ${WRKSRC}/src/github.com/pkg/errors
- @${MV} ${WRKSRC_oauth2} ${WRKSRC}/src/golang.org/x/oauth2
- @${MV} ${WRKSRC_googleapigoclient} ${WRKSRC}/src/google.golang.org/api
- @${MV} ${WRKSRC_gcloudgolang} ${WRKSRC}/src/cloud.google.com/go
- @${MV} ${WRKSRC_net} ${WRKSRC}/src/golang.org/x/net
- @${MV} ${WRKSRC_text} ${WRKSRC}/src/golang.org/x/text
- @${MV} ${WRKSRC_crypto} ${WRKSRC}/src/golang.org/x/crypto
-
do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}; ${SETENV} GOPATH=${WRKSRC} go build .
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}; ${SETENV} GOPATH=${WRKSRC} go build .
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>