aboutsummaryrefslogtreecommitdiff
path: root/net/rdesktop-devel/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2001-12-31 01:12:10 +0000
committerPatrick Li <pat@FreeBSD.org>2001-12-31 01:12:10 +0000
commitbe83d692ca23a1c5a6436ea48e60eb92385ee295 (patch)
tree58276dac1c100298e43e018a97e27f0de2226ec0 /net/rdesktop-devel/Makefile
parent069a21ec6c7e866a0247ac133878f10173a821eb (diff)
downloadports-be83d692ca23a1c5a6436ea48e60eb92385ee295.tar.gz
ports-be83d692ca23a1c5a6436ea48e60eb92385ee295.zip
Notes
Diffstat (limited to 'net/rdesktop-devel/Makefile')
-rw-r--r--net/rdesktop-devel/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/net/rdesktop-devel/Makefile b/net/rdesktop-devel/Makefile
index c962bd51125a..c267da87de34 100644
--- a/net/rdesktop-devel/Makefile
+++ b/net/rdesktop-devel/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= rdesktop
-PORTVERSION= 1.0.0.p19.7.6
+PORTVERSION= 1.1.0.p19.8.2
CATEGORIES= net comms
MASTER_SITES= http://bibl4.oru.se/projects/rdesktop/dist/releases/
-DISTNAME= rdesktop-1.0.0
+DISTNAME= rdesktop-1.1.0
PATCH_SITES= http://bibl4.oru.se/projects/rdesktop/ \
http://bibl4.oru.se/projects/rdesktop/patch19/
-PATCHFILES= rdesktop-unified-patch19-7-6.bz2
+PATCHFILES= rdesktop-unified-patch19-8-2.bz2
PATCH_DIST_STRIP= -p2
MAINTAINER= chris@aims.com.au
@@ -23,17 +23,13 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_OPENSSL= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-openssl
+
MAN1= rdesktop.1
-ALL_TARGET=
-
-do-patch:
- @${EXTRACT_CMD} -dc ${_DISTDIR}/${PATCHFILES} | \
- ${PATCH} ${PATCH_DIST_ARGS}
- @${PERL} -pi.orig -e 's:-O2.*-Wall:${CFLAGS}:g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:/usr/X11R6/:${X11BASE}/:g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:^PREFIX.*:PREFIX=${PREFIX}:g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:^install.*:install\: rdesktop:g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:^.*\(INSTALL\) rdp-srvr.*::g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:<endian.h>:<machine/endian.h>:g' ${WRKSRC}/rdesktop.h
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/rdesktop ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/rdesktop.1 ${PREFIX}/man/man1
.include <bsd.port.mk>