aboutsummaryrefslogtreecommitdiff
path: root/net/rdesktop-devel
diff options
context:
space:
mode:
authorAssar Westerlund <assar@FreeBSD.org>2001-08-28 13:47:15 +0000
committerAssar Westerlund <assar@FreeBSD.org>2001-08-28 13:47:15 +0000
commitdef9cc8a256c9bd105c215eb65f11f80e11b5a8e (patch)
tree663cbaff895a058b0326943b1990585c5e826832 /net/rdesktop-devel
parentc4703a4046ab36d09d8288a3d56e4015142f7f99 (diff)
downloadports-def9cc8a256c9bd105c215eb65f11f80e11b5a8e.tar.gz
ports-def9cc8a256c9bd105c215eb65f11f80e11b5a8e.zip
Notes
Diffstat (limited to 'net/rdesktop-devel')
-rw-r--r--net/rdesktop-devel/Makefile1
-rw-r--r--net/rdesktop-devel/files/patch-aa12
2 files changed, 13 insertions, 0 deletions
diff --git a/net/rdesktop-devel/Makefile b/net/rdesktop-devel/Makefile
index 24663f9decac..6982e3673e78 100644
--- a/net/rdesktop-devel/Makefile
+++ b/net/rdesktop-devel/Makefile
@@ -35,5 +35,6 @@ do-patch:
@${PERL} -pi.orig -e 's:^install.*:install\: rdesktop:g' ${WRKSRC}/Makefile
@${PERL} -pi.orig -e 's:^.*\(INSTALL\) rdp-srvr.*::g' ${WRKSRC}/Makefile
@${PERL} -pi.orig -e 's:<endian.h>:<machine/endian.h>:g' ${WRKSRC}/rdesktop.h
+ @${PATCH} ${PATCH_ARGS} < files/patch-aa
.include <bsd.port.mk>
diff --git a/net/rdesktop-devel/files/patch-aa b/net/rdesktop-devel/files/patch-aa
new file mode 100644
index 000000000000..e9b7e1fb54eb
--- /dev/null
+++ b/net/rdesktop-devel/files/patch-aa
@@ -0,0 +1,12 @@
+--- secure.c~ Mon Aug 27 16:33:56 2001
++++ secure.c Mon Aug 27 16:36:19 2001
+@@ -387,6 +387,9 @@
+ {
+ int hostlen = 2 * ( hostname == 0 ? 0 : strlen (hostname));
+
++ if (hostlen > 30)
++ hostlen = 30;
++
+ out_uint16_be (s, 5); /* unknown */
+ out_uint16_be (s, 0x14);
+ out_uint8 (s, 0x7c);