aboutsummaryrefslogtreecommitdiff
path: root/net/rdesktop
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2001-06-05 02:07:54 +0000
committerDoug Barton <dougb@FreeBSD.org>2001-06-05 02:07:54 +0000
commitf34f153f0c7cab3cc15ae9cbc366f06d92c66a41 (patch)
tree8b0f0ac74bc124afba6ddecf648146fe55029db4 /net/rdesktop
parent189ef38fecaef38eb9edb21b783b4da1d79f8917 (diff)
downloadports-f34f153f0c7cab3cc15ae9cbc366f06d92c66a41.tar.gz
ports-f34f153f0c7cab3cc15ae9cbc366f06d92c66a41.zip
Notes
Diffstat (limited to 'net/rdesktop')
-rw-r--r--net/rdesktop/Makefile35
-rw-r--r--net/rdesktop/distinfo2
-rw-r--r--net/rdesktop/pkg-comment1
-rw-r--r--net/rdesktop/pkg-descr9
-rw-r--r--net/rdesktop/pkg-plist1
5 files changed, 48 insertions, 0 deletions
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
new file mode 100644
index 000000000000..83d0f788c848
--- /dev/null
+++ b/net/rdesktop/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: rdesktop
+# Date created: 13 December 2000
+# Whom: mwest@uct.ac.za
+#
+# $FreeBSD$
+#
+
+PORTNAME= rdesktop
+PORTVERSION= 1.0.0.p19.6.4
+CATEGORIES= net comms
+MASTER_SITES= http://bibl4.oru.se/projects/rdesktop/dist/releases/
+DISTNAME= rdesktop-1.0.0
+
+PATCH_SITES= http://bibl4.oru.se/projects/rdesktop/
+PATCHFILES= rdesktop-unified-patch19-6-4.bz2
+PATCH_DIST_STRIP= -p2
+
+MAINTAINER= chris@aims.com.au
+
+USE_XLIB= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_OPENSSL= yes
+
+MAN1= rdesktop.1
+ALL_TARGET=
+
+do-patch:
+ @${EXTRACT_CMD} -dc ${_DISTDIR}/${PATCHFILES} | \
+ ${PATCH} ${PATCH_DIST_ARGS}
+ @${PERL} -pi.orig -e 's:-O2.*-Wall:${CFLAGS}:g' ${WRKSRC}/Makefile
+ @${PERL} -pi.orig -e 's:/usr/X11R6/:${X11BASE}/:g' ${WRKSRC}/Makefile
+ @${PERL} -pi.orig -e 's:^PREFIX.*:PREFIX=${PREFIX}:g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net/rdesktop/distinfo b/net/rdesktop/distinfo
new file mode 100644
index 000000000000..60188ca892df
--- /dev/null
+++ b/net/rdesktop/distinfo
@@ -0,0 +1,2 @@
+MD5 (rdesktop-1.0.0.tar.bz2) = 2f45a57016fe7ee7930848bbcb94f8b7
+MD5 (rdesktop-unified-patch19-6-4.bz2) = ab20ea8edaf19c4b44170ab4076064b1
diff --git a/net/rdesktop/pkg-comment b/net/rdesktop/pkg-comment
new file mode 100644
index 000000000000..ed48bfd07d49
--- /dev/null
+++ b/net/rdesktop/pkg-comment
@@ -0,0 +1 @@
+RDP client for Windows NT Terminal Server
diff --git a/net/rdesktop/pkg-descr b/net/rdesktop/pkg-descr
new file mode 100644
index 000000000000..10f041c42dda
--- /dev/null
+++ b/net/rdesktop/pkg-descr
@@ -0,0 +1,9 @@
+Rdesktop is an open source client for Windows NT Terminal Server,
+capable of natively speaking its Remote Desktop Protocol (RDP) in
+order to present the user's NT desktop. Unlike Citrix ICA, no server
+extensions are required.
+
+WWW: http://www.rdesktop.org/
+
+--
+mwest@uct.ac.za
diff --git a/net/rdesktop/pkg-plist b/net/rdesktop/pkg-plist
new file mode 100644
index 000000000000..5cae92df98c0
--- /dev/null
+++ b/net/rdesktop/pkg-plist
@@ -0,0 +1 @@
+bin/rdesktop