aboutsummaryrefslogtreecommitdiff
path: root/net/rdist6/Makefile
diff options
context:
space:
mode:
authorPeter Wemm <peter@FreeBSD.org>1996-09-21 05:29:55 +0000
committerPeter Wemm <peter@FreeBSD.org>1996-09-21 05:29:55 +0000
commite88f3d28e71f994d6e608e9a709bb3c10867e745 (patch)
tree8e91526a92ee551d4d1eda0f1cc21df093da9783 /net/rdist6/Makefile
parente7ca1c5ef2967eb43fbaa64e9378ca964f0bbf56 (diff)
downloadports-e88f3d28e71f994d6e608e9a709bb3c10867e745.tar.gz
ports-e88f3d28e71f994d6e608e9a709bb3c10867e745.zip
Notes
Diffstat (limited to 'net/rdist6/Makefile')
-rw-r--r--net/rdist6/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/net/rdist6/Makefile b/net/rdist6/Makefile
index 70a0fd007821..7c8d6d119dc2 100644
--- a/net/rdist6/Makefile
+++ b/net/rdist6/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1995
# Whom: peter
#
-# $Id: Makefile,v 1.6 1996/05/17 11:14:53 peter Exp $
+# $Id: Makefile,v 1.7 1996/09/21 05:12:01 peter Exp $
#
DISTNAME= rdist-6.1.3
@@ -12,13 +12,18 @@ MASTER_SITES= ftp://usc.edu/pub/rdist/
MAINTAINER= peter@FreeBSD.org
-INSTALL_TARGET+=install.man
+# To avoid confusion with /usr/bin/rdist, you may prefer otherwise.
+# Do not forget to deal with pkg/PLIST if you change this.
+RDIST_NAME= rdist6
+
+INSTALL_TARGET= install install.man
+MAKE_ENV+= BUILD_OPT="${CFLAGS}" BUILD_CLIENT=${RDIST_NAME}
post-install:
- strip ${PREFIX}/bin/rdist6
+ strip ${PREFIX}/bin/${RDIST_NAME}
strip ${PREFIX}/bin/rdistd
.if !defined(NOMANCOMPRESS)
- gzip -9nf ${PREFIX}/man/man1/rdist6.1
+ gzip -9nf ${PREFIX}/man/man1/${RDIST_NAME}.1
gzip -9nf ${PREFIX}/man/man8/rdistd.8
.endif