aboutsummaryrefslogtreecommitdiff
path: root/net/recvnet
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-27 15:42:54 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-27 15:42:54 +0000
commit60f854fadfaa865a531362ccaaedbe9af57652c6 (patch)
tree9a9b0919fb5086895331a2314e3f6c0575268314 /net/recvnet
parentb236426ae51df1c2865c6d3cb0dd3acffe5871f8 (diff)
downloadports-60f854fadfaa865a531362ccaaedbe9af57652c6.tar.gz
ports-60f854fadfaa865a531362ccaaedbe9af57652c6.zip
Notes
Diffstat (limited to 'net/recvnet')
-rw-r--r--net/recvnet/Makefile30
-rw-r--r--net/recvnet/distinfo2
-rw-r--r--net/recvnet/pkg-descr8
3 files changed, 40 insertions, 0 deletions
diff --git a/net/recvnet/Makefile b/net/recvnet/Makefile
new file mode 100644
index 000000000000..3204d1bcd868
--- /dev/null
+++ b/net/recvnet/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: recvnet
+# Date created: 27 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= recvnet
+PORTVERSION= 0.0.1
+CATEGORIES= net
+MASTER_SITES= http://www.vanheusden.com/Linux/ \
+ http://critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Recvnet (inverse telnet) is a utility for debugging tcp connections
+
+CFLAGS+= -DVERSION=\"${PORTVERSION}\"
+LDFLAGS+= -lcurses
+
+PLIST_FILES= bin/recvnet
+
+do-build:
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}.o
+ ${CC} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.o -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/recvnet/distinfo b/net/recvnet/distinfo
new file mode 100644
index 000000000000..1e56a2dbe942
--- /dev/null
+++ b/net/recvnet/distinfo
@@ -0,0 +1,2 @@
+MD5 (recvnet-0.0.1.tgz) = d8d52cc17ffc1288316ac54ca2bf5d0e
+SIZE (recvnet-0.0.1.tgz) = 2116
diff --git a/net/recvnet/pkg-descr b/net/recvnet/pkg-descr
new file mode 100644
index 000000000000..03f273ce5408
--- /dev/null
+++ b/net/recvnet/pkg-descr
@@ -0,0 +1,8 @@
+Recvnet is the inverse of telnet. Instead of connecting to some host,
+it listens on a port for incoming connections. When a connection is made,
+you can type a response which will be sent to the client.
+
+This tool has proven to be very useful while debugging Web browsers, httping,
+and others.
+
+WWW: http://www.vanheusden.com/Linux/#recvnet