aboutsummaryrefslogtreecommitdiff
path: root/net/remmina-plugins
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 10:22:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 10:22:41 +0000
commit062ed8d36fcff34f0d3051dd7687377d27558a32 (patch)
tree35173dab2afafdac2c12b688bfc1f1397a7b8cfb /net/remmina-plugins
parent00787ee8ab577b8449043d2c735d6136daf31f74 (diff)
downloadports-062ed8d36fcff34f0d3051dd7687377d27558a32.tar.gz
ports-062ed8d36fcff34f0d3051dd7687377d27558a32.zip
Notes
Diffstat (limited to 'net/remmina-plugins')
-rw-r--r--net/remmina-plugins/Makefile24
-rw-r--r--net/remmina-plugins/bsd.plugin.mk6
2 files changed, 14 insertions, 16 deletions
diff --git a/net/remmina-plugins/Makefile b/net/remmina-plugins/Makefile
index 61da5d548506..046c97797cb0 100644
--- a/net/remmina-plugins/Makefile
+++ b/net/remmina-plugins/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: remmina-plugins
-# Date created: 24 June 2010
-# Whom: Alexander Logvinov <avl@FreeBSD.org>
-#
+# Created by: Alexander Logvinov <avl@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME?= remmina-plugins
PORTVERSION= 0.9.2
@@ -19,29 +15,31 @@ COMMENT?= Remmina plugin system
.include "${.CURDIR}/../remmina-plugins/bsd.plugin.mk"
.else
-OPTIONS= RDP "Install RDP protocol plugin" on \
- VNC "Install VNC protocol plugin" on \
- XDMCP "Install XDMCP protocol plugin" on \
- TELEP "Install Telepathy protocol plugin" on
+OPTIONS_DEFINE= RDP VNC XDMCP TELEP
+OPTIONS_DEFAULT= RDP VNC XDMCP TELEP
+RDP_DESC= RDP protocol plugin
+VNC_DESC= VNC protocol plugin
+XDMCP_DESC= XDMCP protocol plugin
+TELEP_DESC= Telepathy protocol plugin
NO_BUILD= yes
PATCHDIR= # none
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_RDP)
+.if ${PORT_OPTIONS:MRDP}
RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-rdp.so:${PORTSDIR}/net/remmina-plugin-rdp
.endif
-.if !defined(WITHOUT_VNC)
+.if ${PORT_OPTIONS:MVNC}
RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-vnc.so:${PORTSDIR}/net/remmina-plugin-vnc
.endif
-.if !defined(WITHOUT_XDMCP)
+.if ${PORT_OPTIONS:MXDMCP}
RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-xdmcp.so:${PORTSDIR}/net/remmina-plugin-xdmcp
.endif
-.if !defined(WITHOUT_TELEP)
+.if ${PORT_OPTIONS:MTELEP}
RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-telepathy.so:${PORTSDIR}/net/remmina-plugin-telepathy
.endif
diff --git a/net/remmina-plugins/bsd.plugin.mk b/net/remmina-plugins/bsd.plugin.mk
index 6aa1b7e77816..88cddb9915c9 100644
--- a/net/remmina-plugins/bsd.plugin.mk
+++ b/net/remmina-plugins/bsd.plugin.mk
@@ -31,12 +31,12 @@ CONFIGURE_ARGS+=--enable${PKGNAMESUFFIX}
PLIST_SUB+= PLUGIN="${PKGNAMESUFFIX:S,-,,}"
PLIST= ${PKGDIR}/pkg-plist.plugin
-.if defined(WITH_TELEP)
+.if ${PORT_OPTIONS:MTELEP}
PLIST_SUB+= TELEP="" ICONS="@comment "
.else
PLIST_SUB+= TELEP="@comment " ICONS=""
.endif
-.if defined(WITH_SSH)
+.if ${PORT_OPTIONS:MTELEP}
LIB_DEPENDS+= ssh.4:${PORTSDIR}/security/libssh
CONFIGURE_ARGS+=--enable-ssh
PLIST_SUB+= SSH="@comment "
@@ -47,7 +47,7 @@ LDFLAGS+= -fstack-protector
PLIST_SUB+= SSH=""
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTONS:MNLS}
RUN_DEPENDS+= ${LOCALBASE}/share/locale/bg/LC_MESSAGES/remmina-plugins.mo:${PORTSDIR}/net/remmina-plugin-i18n
.endif