aboutsummaryrefslogtreecommitdiff
path: root/net/remmina/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 17:30:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 17:30:12 +0000
commit6abfdf6db901e077e8cac90aa7229a861b65f737 (patch)
treee7e2260c47cd4c95b23c8f6dd565458b565a91fa /net/remmina/Makefile
parentd426ccb2599e41034bfd46fca004ce88d01c6613 (diff)
downloadports-6abfdf6db901e077e8cac90aa7229a861b65f737.tar.gz
ports-6abfdf6db901e077e8cac90aa7229a861b65f737.zip
Notes
Diffstat (limited to 'net/remmina/Makefile')
-rw-r--r--net/remmina/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
new file mode 100644
index 000000000000..97f7c0740646
--- /dev/null
+++ b/net/remmina/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: grdc
+# Date created: 12 April 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+
+PORTNAME= grdc
+PORTVERSION= 0.5.0
+CATEGORIES= net gnome
+MASTER_SITES= SF
+
+MAINTAINER= ports@logvinov.com
+COMMENT= GTK+/GNOME remote desktop client
+
+RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
+
+OPTIONS= VNC "Build with VNC protocol support" off \
+ SSH "Build with SSH tunneling support" off \
+ GCRYPT "Build with libgcrypt support (only with SSH)" off
+
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomehack gnomeprefix glib20 gtk20
+CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_VNC)
+LIB_DEPENDS+= vncclient.0:${PORTSDIR}/net/libvncserver
+.endif
+
+.if defined(WITH_SSH)
+LIB_DEPENDS+= ssh.2:${PORTSDIR}/security/libssh
+.if defined(WITH_GCRYPT)
+LIB_DEPENDS+= gcrypt.16:${PORTSDIR}/security/libgcrypt
+.endif
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|Exec=grdc|Exec=${PREFIX}/bin/grdc|' \
+ ${WRKSRC}/src/grdc.desktop.in
+
+.include <bsd.port.post.mk>