aboutsummaryrefslogtreecommitdiff
path: root/net/remmina
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2010-08-10 02:44:00 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2010-08-10 02:44:00 +0000
commit9e96e0ec98f20e88a3bd826160d1d5c92699ac8e (patch)
tree8d4e36217eec421f926c7a52ecb902ce8ac1e9b0 /net/remmina
parent8bd22d88d41f6c8adcfa873a0ef8ca7dcba090b9 (diff)
downloadports-9e96e0ec98f20e88a3bd826160d1d5c92699ac8e.tar.gz
ports-9e96e0ec98f20e88a3bd826160d1d5c92699ac8e.zip
Notes
Diffstat (limited to 'net/remmina')
-rw-r--r--net/remmina/Makefile70
-rw-r--r--net/remmina/distinfo6
-rw-r--r--net/remmina/files/pkg-message.in4
-rw-r--r--net/remmina/pkg-descr2
-rw-r--r--net/remmina/pkg-plist29
5 files changed, 46 insertions, 65 deletions
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index fbd89c2ee7e0..81b1e8a8ebad 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -6,91 +6,77 @@
#
PORTNAME= remmina
-PORTVERSION= 0.7.5
-PORTREVISION= 2
+PORTVERSION= 0.8.1
CATEGORIES= net gnome
-MASTER_SITES= SF/${PORTNAME}/0.7/
+MASTER_SITES= SF/${PORTNAME}/0.8
MAINTAINER= avl@FreeBSD.org
COMMENT= The GTK+ Remote Desktop Client
-RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
+OPTIONS= SSH "Build with SSH tunneling support" on \
+ GCRYPT "Build with libgcrypt support for password encryption" on \
+ TERM "Build with terminal support" on \
+ AVAHI "Build with Avahi support" on \
+ UNIQUE "Build with Unique-App support" on
-OPTIONS= VNC "Build with VNC protocol support" off \
- GNUTLS "Build VNC with GNUTLS encryption support" off \
- XDMCP "Build with XDMCP protocol support" off \
- SSH "Build with SSH tunneling support" off \
- GCRYPT "Build with libgcrypt support for password encryption" off \
- TERM "Build with terminal support" off \
- AVAHI "Build with Avahi support" off \
- UNIQUE "Build with Unique-App support" off
-
-MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= glib20 gtk20 desktopfileutils
INSTALLS_ICONS= yes
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -Wl,-rpath -Wl,${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS}"
+SUB_FILES= pkg-message
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-.if defined(WITH_VNC)
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
-.if defined(WITH_GNUTLS)
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
-.endif
-.else
-CONFIGURE_ARGS+= --disable-vnc
-.endif
-
-.if defined(WITH_XDMCP)
-RUN_DEPENDS+= Xephyr:${PORTSDIR}/x11-servers/xephyr
-.endif
-
-.if defined(WITH_SSH)
-LIB_DEPENDS+= ssh.4:${PORTSDIR}/security/libssh
+.if !defined(WITHOUT_SSH)
+BUILD_DEPENDS+= ${LOCALBASE}/include/libssh/libssh.h:${PORTSDIR}/security/libssh
+RUN_DEPENDS+= ${LOCALBASE}/lib/libssh.so.4:${PORTSDIR}/security/libssh
.if ${OSVERSION} >= 800040
LDFLAGS+= -fstack-protector
.endif
.else
-CONFIGURE_ARGS+= --disable-ssh
+CONFIGURE_ARGS+=--disable-ssh
.endif
-.if defined(WITH_GCRYPT)
+.if !defined(WITHOUT_GCRYPT)
LIB_DEPENDS+= gcrypt.17:${PORTSDIR}/security/libgcrypt
.else
-CONFIGURE_ARGS+= --disable-gcrypt
+CONFIGURE_ARGS+=--disable-gcrypt
.endif
-.if defined(WITH_TERM)
+.if !defined(WITHOUT_TERM)
USE_GNOME+= vte
.else
-CONFIGURE_ARGS+= --disable-vte
+CONFIGURE_ARGS+=--disable-vte
.endif
-.if defined(WITH_AVAHI)
+.if !defined(WITHOUT_AVAHI)
LIB_DEPENDS+= avahi-ui.0:${PORTSDIR}/net/avahi-gtk
.else
-CONFIGURE_ARGS+= --disable-avahi
+CONFIGURE_ARGS+=--disable-avahi
.endif
-.if defined(WITH_UNIQUE)
+.if !defined(WITHOUT_UNIQUE)
LIB_DEPENDS+= unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
.else
-CONFIGURE_ARGS+= --disable-unique
+CONFIGURE_ARGS+=--disable-unique
.endif
post-install:
@-update-desktop-database
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/remmina/distinfo b/net/remmina/distinfo
index d2ed7eda6096..15eb07c61545 100644
--- a/net/remmina/distinfo
+++ b/net/remmina/distinfo
@@ -1,3 +1,3 @@
-MD5 (remmina-0.7.5.tar.gz) = 9b787672b63c57ca9323072f1304ef10
-SHA256 (remmina-0.7.5.tar.gz) = 3e2ea9c57003cf8043378fa797e0f2fd6f8a3c3817ece27fa7b381101ec9000a
-SIZE (remmina-0.7.5.tar.gz) = 633137
+MD5 (remmina-0.8.1.tar.gz) = 88905510156d0b71b741cae34e2e46c8
+SHA256 (remmina-0.8.1.tar.gz) = 48080b63f471b8668e2327fdeacdf1064e6b95c3774d45d3c03a6abfa1ad1cdb
+SIZE (remmina-0.8.1.tar.gz) = 334912
diff --git a/net/remmina/files/pkg-message.in b/net/remmina/files/pkg-message.in
new file mode 100644
index 000000000000..1aaa80b65173
--- /dev/null
+++ b/net/remmina/files/pkg-message.in
@@ -0,0 +1,4 @@
+
+ Remmina is pretty useless without a plugins.
+ Consider installing net/remmina-plugins.
+
diff --git a/net/remmina/pkg-descr b/net/remmina/pkg-descr
index fa23a7f47332..554224b5b5a3 100644
--- a/net/remmina/pkg-descr
+++ b/net/remmina/pkg-descr
@@ -15,6 +15,6 @@ The Remmina main program:
* Floating toolbar in fullscreen mode, allows you to switch between modes,
toggle keyboard grabbing, minimize, etc.
* Tabbed interface, optionally managed by groups
- * Supported network protocols: RDP, VNC, XDMCP, SSH, Avahi
+ * Supported network protocols: RDP, NX, Telepathy, VNC, XDMCP, SSH, Avahi
WWW: http://remmina.sourceforge.net/
diff --git a/net/remmina/pkg-plist b/net/remmina/pkg-plist
index b7283f12ffd1..9fc68358d2e2 100644
--- a/net/remmina/pkg-plist
+++ b/net/remmina/pkg-plist
@@ -1,4 +1,6 @@
bin/remmina
+include/remmina/plugin.h
+include/remmina/types.h
share/applications/remmina.desktop
%%DATADIR%%/icons/hicolor/16x16/actions/remmina-fit-window.png
%%DATADIR%%/icons/hicolor/16x16/actions/remmina-leave-fullscreen.png
@@ -6,12 +8,6 @@ share/applications/remmina.desktop
%%DATADIR%%/icons/hicolor/16x16/actions/remmina-scrolled-fullscreen.png
%%DATADIR%%/icons/hicolor/16x16/actions/remmina-viewport-fullscreen.png
%%DATADIR%%/icons/hicolor/16x16/actions/remmina-switch-page.png
-%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-rdp.png
-%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-rdp-ssh.png
-%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-vnc.png
-%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-vnc-ssh.png
-%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-xdmcp.png
-%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-xdmcp-ssh.png
%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-sftp.png
%%DATADIR%%/icons/hicolor/22x22/actions/remmina-fit-window.png
%%DATADIR%%/icons/hicolor/22x22/actions/remmina-leave-fullscreen.png
@@ -19,12 +15,6 @@ share/applications/remmina.desktop
%%DATADIR%%/icons/hicolor/22x22/actions/remmina-scrolled-fullscreen.png
%%DATADIR%%/icons/hicolor/22x22/actions/remmina-viewport-fullscreen.png
%%DATADIR%%/icons/hicolor/22x22/actions/remmina-switch-page.png
-%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-rdp.png
-%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-rdp-ssh.png
-%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-vnc.png
-%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-vnc-ssh.png
-%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-xdmcp.png
-%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-xdmcp-ssh.png
%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-sftp.png
%%NLS%%share/locale/bg/LC_MESSAGES/remmina.mo
%%NLS%%share/locale/de/LC_MESSAGES/remmina.mo
@@ -52,13 +42,14 @@ share/icons/hicolor/48x48/apps/remmina.png
share/icons/hicolor/scalable/apps/remmina.svg
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrm include/remmina
@dirrm %%DATADIR%%/icons/hicolor/22x22/actions
-@dirrm %%DATADIR%%/icons/hicolor/22x22/emblems
-@dirrm %%DATADIR%%/icons/hicolor/22x22
+@dirrmtry %%DATADIR%%/icons/hicolor/22x22/emblems
+@dirrmtry %%DATADIR%%/icons/hicolor/22x22
@dirrm %%DATADIR%%/icons/hicolor/16x16/actions
-@dirrm %%DATADIR%%/icons/hicolor/16x16/emblems
-@dirrm %%DATADIR%%/icons/hicolor/16x16
-@dirrm %%DATADIR%%/icons/hicolor
-@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%
+@dirrmtry %%DATADIR%%/icons/hicolor/16x16/emblems
+@dirrmtry %%DATADIR%%/icons/hicolor/16x16
+@dirrmtry %%DATADIR%%/icons/hicolor
+@dirrmtry %%DATADIR%%/icons
+@dirrmtry %%DATADIR%%
@dirrmtry share/applications