aboutsummaryrefslogtreecommitdiff
path: root/net/remmina
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 10:22:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 10:22:41 +0000
commit062ed8d36fcff34f0d3051dd7687377d27558a32 (patch)
tree35173dab2afafdac2c12b688bfc1f1397a7b8cfb /net/remmina
parent00787ee8ab577b8449043d2c735d6136daf31f74 (diff)
downloadports-062ed8d36fcff34f0d3051dd7687377d27558a32.tar.gz
ports-062ed8d36fcff34f0d3051dd7687377d27558a32.zip
Notes
Diffstat (limited to 'net/remmina')
-rw-r--r--net/remmina/Makefile29
1 files changed, 15 insertions, 14 deletions
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index 8e0a29654521..3ad1277b9ea0 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -10,11 +10,12 @@ MASTER_SITES= SF/${PORTNAME}/0.9
MAINTAINER= fluffy@FreeBSD.org
COMMENT= The GTK+ Remote Desktop Client
-OPTIONS= SSH "Build with SSH tunneling support" on \
- GCRYPT "Build with libgcrypt support for password encryption" on \
- TERM "Build with terminal support" on \
- AVAHI "Build with Avahi support" on \
- UNIQUE "Build with Unique-App support" on
+OPTIONS_DEFINE= SSH GCRYPT TERM AVAHI UNIQUE NLS
+OPTIONS_DEFAULT= SSH GCRYPT TERM AVAHI UNIQUE
+SSH_DESC= SSH tunneling support
+GCRYPT_DESC= libgcrypt support for password encryption
+TERM_DESC= terminal support
+UNIQUE_DESC= Unique-App support
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -29,15 +30,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(WITHOUT_SSH)
+.if ${PORT_OPTIONS:MSSH}
BUILD_DEPENDS+= ${LOCALBASE}/include/libssh/libssh.h:${PORTSDIR}/security/libssh
RUN_DEPENDS+= ${LOCALBASE}/lib/libssh.so.4:${PORTSDIR}/security/libssh
.if ${OSVERSION} >= 800040
@@ -47,25 +48,25 @@ LDFLAGS+= -fstack-protector
CONFIGURE_ARGS+=--disable-ssh
.endif
-.if !defined(WITHOUT_GCRYPT)
+.if ${PORT_OPTIONS:MGCRYPT}
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
.else
CONFIGURE_ARGS+=--disable-gcrypt
.endif
-.if !defined(WITHOUT_TERM)
+.if ${PORT_OPTIONS:MTERM}
USE_GNOME+= vte
.else
CONFIGURE_ARGS+=--disable-vte
.endif
-.if !defined(WITHOUT_AVAHI)
+.if ${PORT_OPTIONS:MAVAHI}
LIB_DEPENDS+= avahi-ui.0:${PORTSDIR}/net/avahi-gtk
.else
CONFIGURE_ARGS+=--disable-avahi
.endif
-.if !defined(WITHOUT_UNIQUE)
+.if ${PORT_OPTIONS:MUNIQUE}
LIB_DEPENDS+= unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
.else
CONFIGURE_ARGS+=--disable-unique