aboutsummaryrefslogtreecommitdiff
path: root/net/rexx-sock/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2005-06-10 08:07:05 +0000
committerPatrick Li <pat@FreeBSD.org>2005-06-10 08:07:05 +0000
commit19a4dd6f5a663a90878a77bb6565b8b5cfcdcbb5 (patch)
treeff2172c7b8e9ac88dfc626ff58a3b95d0e19570b /net/rexx-sock/Makefile
parentc88bfadd6819b105e81c8d8c23ca69cf8f8ec3bf (diff)
downloadports-19a4dd6f5a663a90878a77bb6565b8b5cfcdcbb5.tar.gz
ports-19a4dd6f5a663a90878a77bb6565b8b5cfcdcbb5.zip
Notes
Diffstat (limited to 'net/rexx-sock/Makefile')
-rw-r--r--net/rexx-sock/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/net/rexx-sock/Makefile b/net/rexx-sock/Makefile
index c3d7a0edafc4..8c8a9f01b5b9 100644
--- a/net/rexx-sock/Makefile
+++ b/net/rexx-sock/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= sock
-PORTVERSION= 1.3
-PORTREVISION= 2
+PORTVERSION= 1.4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= rxsock
@@ -21,13 +20,21 @@ COMMENT= A function package for Rexx programmers to create sockets
BUILD_DEPENDS= rexx:${PORTSDIR}/lang/rexx-regina
RUN_DEPENDS= rexx:${PORTSDIR}/lang/rexx-regina
+USE_REINPLACE= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-rexx=regina
-USE_GMAKE= yes
+MAKE_ARGS= INSTALL="${INSTALL}"
INSTALLS_SHLIB= yes
+
DATADIR= ${PREFIX}/share/rx${PORTNAME}
-post-extract:
- @${CHMOD} +x ${WRKSRC}/install-sh
+post-patch:
+ @${REINPLACE_CMD} -e 's|ld -Bdynamic -Bshareable|$${CC} -shared|g' \
+ ${WRKSRC}/configure
+.for file in Makefile.in rxsock-config.in
+ @${REINPLACE_CMD} -e 's|-lc||g' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>