aboutsummaryrefslogtreecommitdiff
path: root/net/ripe-whois
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2007-01-09 14:07:59 +0000
committerVasil Dimov <vd@FreeBSD.org>2007-01-09 14:07:59 +0000
commit3dc622a664e87a37a1252cfef43789b0c367649d (patch)
tree2188a19b9fce2abdcfb5d61a8f60b88406fe7050 /net/ripe-whois
parentfc138918a9a509b8f475c6fd6514bc3f85748b8e (diff)
downloadports-3dc622a664e87a37a1252cfef43789b0c367649d.tar.gz
ports-3dc622a664e87a37a1252cfef43789b0c367649d.zip
Notes
Diffstat (limited to 'net/ripe-whois')
-rw-r--r--net/ripe-whois/Makefile29
-rw-r--r--net/ripe-whois/distinfo6
-rw-r--r--net/ripe-whois/files/patch-whois3.c16
-rw-r--r--net/ripe-whois/pkg-descr2
4 files changed, 26 insertions, 27 deletions
diff --git a/net/ripe-whois/Makefile b/net/ripe-whois/Makefile
index dba15c309bf7..f7bad8a7d072 100644
--- a/net/ripe-whois/Makefile
+++ b/net/ripe-whois/Makefile
@@ -6,22 +6,37 @@
#
PORTNAME= ripe-whois
-PORTVERSION= 3.1.1v6
-PORTREVISION= 1
+PORTVERSION= 3.2.2
CATEGORIES= net ipv6
-MASTER_SITES= ftp://ftp.ripe.net/tools/
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= whois
+DISTNAME= whois3-${PORTVERSION}
MAINTAINER= lerik@nolink.net
COMMENT= The RIPE whois client version 3
USE_PERL5_BUILD= yes
-WRKSRC= ${WRKDIR}/whois-${PORTVERSION}
-
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= whois3.1
PLIST_FILES= bin/whois3
+post-patch::
+ ${REINPLACE_CMD} -E \
+ -e '/^bin_PROGRAMS =/ s/whois\$$\(EXEEXT\)/whois3$$(EXEEXT)/' \
+ ${WRKSRC}/Makefile.in
+
+.if !defined(NOPORTDOCS)
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/doc
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+PORTDOCS= HELP.txt FLAGS.txt
+.else
+post-patch::
+ ${REINPLACE_CMD} -E \
+ -e '/^install-data-am:/ s/install-whoisdataDATA//' \
+ ${WRKSRC}/doc/Makefile.in
+.endif
+
.include <bsd.port.mk>
diff --git a/net/ripe-whois/distinfo b/net/ripe-whois/distinfo
index 9c1988959add..5ea85573342d 100644
--- a/net/ripe-whois/distinfo
+++ b/net/ripe-whois/distinfo
@@ -1,3 +1,3 @@
-MD5 (ripe-whois-3.1.1v6.tar.gz) = 07802f588874d66690e04ec73b02fb17
-SHA256 (ripe-whois-3.1.1v6.tar.gz) = 00692e48b3d1b38cadd5caaf5609182218375a8fab11cb3ef49dc5a8f5b5394d
-SIZE (ripe-whois-3.1.1v6.tar.gz) = 40608
+MD5 (whois3-3.2.2.tar.gz) = d25bbe0c5bcf679bd9f9ead30bb0a71a
+SHA256 (whois3-3.2.2.tar.gz) = 426fed6dd7ecb77e0fe6740ceaa72e2749b5421fed7820f4cd4c35a48d407792
+SIZE (whois3-3.2.2.tar.gz) = 94587
diff --git a/net/ripe-whois/files/patch-whois3.c b/net/ripe-whois/files/patch-whois3.c
deleted file mode 100644
index 694f1a48af29..000000000000
--- a/net/ripe-whois/files/patch-whois3.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- whois3.c.orig Thu Aug 5 16:41:00 2004
-+++ whois3.c Thu Aug 5 16:59:16 2004
-@@ -130,7 +130,12 @@
- /* create the socket */
- fd = socket(dest.ss_family, SOCK_STREAM, 0);
- if (fd < 0)
-- fatal("cannot create the socket: %s", strerror(errno));
-+ {
-+ if (errno == EPROTONOSUPPORT)
-+ continue;
-+ else
-+ fatal("cannot create the socket: %s", strerror(errno));
-+ }
-
- /* perform the connection */
- err = connect(fd, (struct sockaddr *) &dest, destlen);
diff --git a/net/ripe-whois/pkg-descr b/net/ripe-whois/pkg-descr
index f5cd760e4a0d..0d3501a7cb2d 100644
--- a/net/ripe-whois/pkg-descr
+++ b/net/ripe-whois/pkg-descr
@@ -3,4 +3,4 @@ whois client with IPv6 support. This whois client is customized
for taking advantage of all the extended capabilities of the
RIPE whois db.
-WWW: http://www.ripe.net/db/
+WWW: http://whois.sf.net