aboutsummaryrefslogtreecommitdiff
path: root/net/ripe-whois
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-06 08:57:41 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-06 08:57:41 +0000
commitdd986f9cbf11d39f34dbbdb98c809dc33bbef476 (patch)
treeae1cbe69174970d999c3833a5aa86a7b8841e42f /net/ripe-whois
parentbd9c052fd8a93db28f6eb42c7d6e72555a4355c5 (diff)
downloadports-dd986f9cbf11d39f34dbbdb98c809dc33bbef476.tar.gz
ports-dd986f9cbf11d39f34dbbdb98c809dc33bbef476.zip
Notes
Diffstat (limited to 'net/ripe-whois')
-rw-r--r--net/ripe-whois/Makefile1
-rw-r--r--net/ripe-whois/files/patch-whois3.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/net/ripe-whois/Makefile b/net/ripe-whois/Makefile
index a93e2b82c927..dba15c309bf7 100644
--- a/net/ripe-whois/Makefile
+++ b/net/ripe-whois/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ripe-whois
PORTVERSION= 3.1.1v6
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ripe.net/tools/
diff --git a/net/ripe-whois/files/patch-whois3.c b/net/ripe-whois/files/patch-whois3.c
new file mode 100644
index 000000000000..694f1a48af29
--- /dev/null
+++ b/net/ripe-whois/files/patch-whois3.c
@@ -0,0 +1,16 @@
+--- whois3.c.orig Thu Aug 5 16:41:00 2004
++++ whois3.c Thu Aug 5 16:59:16 2004
+@@ -130,7 +130,12 @@
+ /* create the socket */
+ fd = socket(dest.ss_family, SOCK_STREAM, 0);
+ if (fd < 0)
+- fatal("cannot create the socket: %s", strerror(errno));
++ {
++ if (errno == EPROTONOSUPPORT)
++ continue;
++ else
++ fatal("cannot create the socket: %s", strerror(errno));
++ }
+
+ /* perform the connection */
+ err = connect(fd, (struct sockaddr *) &dest, destlen);