aboutsummaryrefslogtreecommitdiff
path: root/net/roadrunner
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-26 21:39:16 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-26 21:39:16 +0000
commitf35e5c3071894deeb0964014abb202b139253577 (patch)
treed3973620cf05b7d35d7176eb7526d6e1a111d1ce /net/roadrunner
parent0c814fde44c7c730df8ba12bdd80bbebd85c20bb (diff)
Notes
Diffstat (limited to 'net/roadrunner')
-rw-r--r--net/roadrunner/Makefile4
-rw-r--r--net/roadrunner/files/patch-ltmain.sh51
2 files changed, 53 insertions, 2 deletions
diff --git a/net/roadrunner/Makefile b/net/roadrunner/Makefile
index 83c34e4ae640..cf2c9940c640 100644
--- a/net/roadrunner/Makefile
+++ b/net/roadrunner/Makefile
@@ -14,8 +14,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ahze@ahze.net
COMMENT= A portable BEEP protocol implementation
-USE_GNOME= glib20 libxml2 pkgconfig lthack
-USE_LIBTOOL_VER=13
+USE_GNOME= glib20 libxml2 pkgconfig
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
USE_GMAKE= yes
diff --git a/net/roadrunner/files/patch-ltmain.sh b/net/roadrunner/files/patch-ltmain.sh
new file mode 100644
index 000000000000..bb660972a6d1
--- /dev/null
+++ b/net/roadrunner/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Thu May 22 16:42:22 2003
++++ ltmain.sh Tue May 27 12:12:52 2003
+@@ -1072,7 +1072,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1082,8 +1082,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2498,6 +2506,9 @@
+ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4325,10 +4336,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"