aboutsummaryrefslogtreecommitdiff
path: root/net/rsync/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-01-15 13:40:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-01-15 13:40:28 +0000
commitc4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8 (patch)
tree98f96307b5a32cecd5d4e2104c22673c560b9789 /net/rsync/Makefile
parent56b2cbf1c5abcce2be96f0aa252e4df4d8d99dd2 (diff)
downloadports-c4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8.tar.gz
ports-c4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8.zip
Notes
Diffstat (limited to 'net/rsync/Makefile')
-rw-r--r--net/rsync/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 3e31fd5b2b31..523f2954f02c 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -27,14 +27,12 @@ MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --disable-debug --enable-ipv6 \
--with-rsyncd-conf=${PREFIX}/etc/rsyncd.conf
-.if !defined(NOPORTDOCS)
PORTDOCS= NEWS README csprotocol.txt tech_report.tex
-.endif
MAN1= rsync.1
MAN5= rsyncd.conf.5
-OPTIONS_DEFINE= POPT_PORT SSH FLAGS ATIMES ACL ICONV TIMELIMIT RENAMED
+OPTIONS_DEFINE= POPT_PORT SSH FLAGS ATIMES ACL ICONV TIMELIMIT RENAMED DOCS
POPT_PORT_DESC= Use popt from devel/popt instead of bundled one
SSH_DESC= Use SSH instead of RSH
FLAGS_DESC= File system flags support patch, adds --fileflags
@@ -132,7 +130,7 @@ post-install:
@[ -f ${PREFIX}/etc/rsyncd.conf ] || \
${CP} ${PREFIX}/etc/rsyncd.conf.sample \
${PREFIX}/etc/rsyncd.conf
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif