aboutsummaryrefslogtreecommitdiff
path: root/net/rsync
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-02-22 11:50:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-02-22 11:50:38 +0000
commitc45a5502eaedb61eac16d4bce7684812fb00687b (patch)
treeb966cc707584b39b25e02618e47791d2a9f8615a /net/rsync
parent29634c01cff8266aa8c600bf66086c2212a8602c (diff)
downloadports-c45a5502eaedb61eac16d4bce7684812fb00687b.tar.gz
ports-c45a5502eaedb61eac16d4bce7684812fb00687b.zip
Notes
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 581d631ca238..a8e5bb945abb 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -39,6 +39,7 @@ MAN5= rsyncd.conf.5
OPTIONS= POPT_PORT "Use popt from devel/popt instead of bundled one" off \
TIMELIMIT "Time limit patch" on \
FLAGSP "File system flags support patch, adds --flags" off \
+ ATIMES "Preserve file atimes; adds --atimes" off \
ACLSP "ACL support patch, adds --acls" off \
SSH "Use SSH instead of RSH" on
@@ -60,6 +61,25 @@ EXTRA_PATCHES+= ${WRKSRC}/patches/time-limit.diff
EXTRA_PATCHES+= ${WRKSRC}/patches/flags.diff
.endif
+# The atimes patch works only by itself; it does not patch cleanly when used
+# alongside timelimit, flags, or acls.
+#
+.if defined(WITH_ATIMES)
+EXTRA_PATCHES+= ${WRKSRC}/patches/atimes.diff
+
+.if defined(WITH_ACLSP)
+IGNORE= ACLs and atimes patches don't work together; please re-run 'make config' and disable one of them
+.endif
+
+.if !defined(WITHOUT_TIMELIMIT)
+IGNORE= timelimit and atimes patches don't work together; please re-run 'make config' and disable one of them
+.endif
+
+.if defined(WITH_FLAGSP)
+IGNORE= Flags and atimes patches don't work together; please re-run 'make config' and disable one of them
+.endif
+.endif
+
.if defined(WITH_ACLSP)
EXTRA_PATCHES+= ${PATCHDIR}/extra-patches-acls.diff ${WRKSRC}/patches/acls.diff
CONFIGURE_ARGS+=--enable-acl-support