aboutsummaryrefslogtreecommitdiff
path: root/net/rsync
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-03-08 11:40:26 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-03-08 11:40:26 +0000
commit31bb97e684e4f8b217087195fdf98e175b84cb58 (patch)
tree87982da9cc3ee4f4f23f4458b7d6c9aa53cc4760 /net/rsync
parente65592ef9df99c450dd61a451f2855cc54e36eb1 (diff)
downloadports-31bb97e684e4f8b217087195fdf98e175b84cb58.tar.gz
ports-31bb97e684e4f8b217087195fdf98e175b84cb58.zip
Notes
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile12
-rw-r--r--net/rsync/files/ssh-patch-README8
-rw-r--r--net/rsync/files/ssh-patch-options.c5
-rw-r--r--net/rsync/files/ssh-patch-rsync.121
-rw-r--r--net/rsync/files/ssh-patch-rsync.h5
-rw-r--r--net/rsync/pkg-message7
6 files changed, 58 insertions, 0 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 242849c10ea8..3feb0d11b7ce 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -8,6 +8,7 @@
PORTNAME= rsync
PORTVERSION= 2.4.6
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://samba.anu.edu.au/pub/rsync/ \
ftp://sunsite.auc.dk/pub/unix/rsync/ \
@@ -25,6 +26,16 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 400016
+USE_SSH?= yes
+.else
+USE_SSH?= no
+.endif
+
+.if ${USE_SSH:U} == YES
+EXTRA_PATCHES= ${FILESDIR}/ssh-patch-*
+.endif
+
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS= --enable-ipv6
.else
@@ -48,5 +59,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/rsync
${INSTALL_DATA} ${WRKSRC}/tech_report.tex ${PREFIX}/share/doc/rsync
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/net/rsync/files/ssh-patch-README b/net/rsync/files/ssh-patch-README
new file mode 100644
index 000000000000..5daf36387947
--- /dev/null
+++ b/net/rsync/files/ssh-patch-README
@@ -0,0 +1,8 @@
+--- README.orig Tue Sep 5 19:46:43 2000
++++ README Thu Mar 8 03:31:32 2001
+@@ -60 +60 @@
+- -e, --rsh=COMMAND specify rsh replacement
++ -e, --rsh=COMMAND specify rsh replacement (default ssh)
+@@ -96 +96 @@
+-rsh or ssh system. Using ssh is recommended for its security
++rsh or ssh system. Using rsh is discouraged for lack of security
diff --git a/net/rsync/files/ssh-patch-options.c b/net/rsync/files/ssh-patch-options.c
new file mode 100644
index 000000000000..98e30ffc1e67
--- /dev/null
+++ b/net/rsync/files/ssh-patch-options.c
@@ -0,0 +1,5 @@
+--- options.c.orig Thu Mar 8 03:31:32 2001
++++ options.c Thu Mar 8 03:31:32 2001
+@@ -141 +141 @@
+- rprintf(F," -e, --rsh=COMMAND specify rsh replacement\n");
++ rprintf(F," -e, --rsh=COMMAND specify rsh replacement (default %s)\n", RSYNC_RSH);
diff --git a/net/rsync/files/ssh-patch-rsync.1 b/net/rsync/files/ssh-patch-rsync.1
new file mode 100644
index 000000000000..a8ab98002689
--- /dev/null
+++ b/net/rsync/files/ssh-patch-rsync.1
@@ -0,0 +1,21 @@
+--- rsync.1.orig Tue Sep 5 19:46:43 2000
++++ rsync.1 Thu Mar 8 03:34:47 2001
+@@ -89,2 +89,2 @@
+-Once installed you can use rsync to any machine that you can use rsh
+-to\&. rsync uses rsh for its communications, unless both the source and
++Once installed you can use rsync to any machine that you can use ssh
++to\&. rsync uses ssh for its communications, unless both the source and
+@@ -93 +93 @@
+-You can also specify an alternative to rsh, by either using the -e
++You can also specify an alternative to ssh, by either using the -e
+@@ -273 +273 @@
+- -e, --rsh=COMMAND specify rsh replacement
++ -e, --rsh=COMMAND specify rsh replacement (default ssh)
+@@ -566,2 +566,2 @@
+-remote copies of rsync\&. By default, rsync will use rsh, but you may
+-like to instead use ssh because of its high security\&.
++remote copies of rsync\&. By default, rsync will use ssh, but you may
++need to use the much less secure rsh for compatibility reasons\&.
+@@ -890 +890 @@
+- rsh remotehost /bin/true > out\&.dat
++ ssh remotehost /bin/true > out\&.dat
diff --git a/net/rsync/files/ssh-patch-rsync.h b/net/rsync/files/ssh-patch-rsync.h
new file mode 100644
index 000000000000..80ccdcc2bdfd
--- /dev/null
+++ b/net/rsync/files/ssh-patch-rsync.h
@@ -0,0 +1,5 @@
+--- rsync.h.orig Sat Aug 19 06:10:39 2000
++++ rsync.h Thu Mar 8 03:31:33 2001
+@@ -75 +75 @@
+-#define RSYNC_RSH "rsh"
++#define RSYNC_RSH "ssh"
diff --git a/net/rsync/pkg-message b/net/rsync/pkg-message
new file mode 100644
index 000000000000..f9109fce4cf1
--- /dev/null
+++ b/net/rsync/pkg-message
@@ -0,0 +1,7 @@
+************************************************************
+Note that rsync now uses SSH as the transport by default.
+
+If you still need to use RSH instead, please specify
+"-e rsh" in the rsync command line or set the environment
+variable RSYNC_RSH to "rsh".
+************************************************************