aboutsummaryrefslogtreecommitdiff
path: root/net/rtpbreak
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-02-18 21:13:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-02-18 21:13:02 +0000
commitfcb98a504a4b2d61662773d959b7cc3ee239eb09 (patch)
tree6c12a9e824cf39ccd0922fe8c2e9a8017ad5fc34 /net/rtpbreak
parent154ea12c2bcc68e342c6a93a66297844b157ee60 (diff)
downloadports-fcb98a504a4b2d61662773d959b7cc3ee239eb09.tar.gz
ports-fcb98a504a4b2d61662773d959b7cc3ee239eb09.zip
Notes
Diffstat (limited to 'net/rtpbreak')
-rw-r--r--net/rtpbreak/Makefile3
-rw-r--r--net/rtpbreak/files/patch-net.h10
2 files changed, 12 insertions, 1 deletions
diff --git a/net/rtpbreak/Makefile b/net/rtpbreak/Makefile
index cb4de60444a0..57a08648876b 100644
--- a/net/rtpbreak/Makefile
+++ b/net/rtpbreak/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rtpbreak
PORTVERSION= 1.3a
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://dallachiesa.com/code/rtpbreak/
EXTRACT_SUFX= .tgz
@@ -14,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= prudhvi-krishna-bsd@surapaneni.in
COMMENT= Detects, reconstructs, and analyzes any RTP session
-BUILD_DEPENDS= libnet11-config:${PORTSDIR}/net/libnet
+LIB_DEPENDS= net:${PORTSDIR}/net/libnet
MAKE_ARGS+= CFLAGS="-Wall -O3 -I${LOCALBASE}/include/libnet11" \
LIBS="-L${LOCALBASE}/lib/libnet11 -lpcap -lnet"
diff --git a/net/rtpbreak/files/patch-net.h b/net/rtpbreak/files/patch-net.h
new file mode 100644
index 000000000000..0f91c50227b9
--- /dev/null
+++ b/net/rtpbreak/files/patch-net.h
@@ -0,0 +1,10 @@
+--- src/net.h.orig 2008-05-05 19:05:21.000000000 +0200
++++ src/net.h 2013-02-18 07:48:54.000000000 +0100
+@@ -26,6 +26,7 @@
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
++#include <netinet/udp.h>
+ #include <arpa/inet.h>
+ #include <pcap.h>
+ #include <libnet.h>