aboutsummaryrefslogtreecommitdiff
path: root/net/rtpproxy
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-12-22 17:29:17 +0000
committerChris Rees <crees@FreeBSD.org>2012-12-22 17:29:17 +0000
commit6d86e584d65c2744d5ccd8721e4848a5adb6ed44 (patch)
treee01f9ded39121d9217d20d72977d7bb3100c4b6d /net/rtpproxy
parent48b6e73d98ecec3257be2b95ca430bd8cdd5fdfd (diff)
downloadports-6d86e584d65c2744d5ccd8721e4848a5adb6ed44.tar.gz
ports-6d86e584d65c2744d5ccd8721e4848a5adb6ed44.zip
Notes
Diffstat (limited to 'net/rtpproxy')
-rw-r--r--net/rtpproxy/Makefile14
-rw-r--r--net/rtpproxy/pkg-install35
2 files changed, 5 insertions, 44 deletions
diff --git a/net/rtpproxy/Makefile b/net/rtpproxy/Makefile
index 1c16c3908bac..c8265203dab6 100644
--- a/net/rtpproxy/Makefile
+++ b/net/rtpproxy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rtpproxy
-# Date created: 20 April 2005
-# Whom: sobomax@FreeBSD.org
-#
+# Created by: sobomax
# $FreeBSD$
-#
PORTNAME= rtpproxy
PORTVERSION= 1.2.1
@@ -12,7 +8,7 @@ CATEGORIES= net
MASTER_SITES= http://www.rtpproxy.org/chrome/site/
MAINTAINER= sobomax@FreeBSD.org
-COMMENT= A high-performance RTP proxy server for the SIP Express Router (SER)
+COMMENT= High-performance RTP proxy server for the SIP Express Router (SER)
LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
@@ -22,13 +18,13 @@ CPPFLAGS+= -I${LOCALBASE}/include
#CONFIGURE_ARGS= --mandir=${LOCALBASE}/man
MAN8= rtpproxy.8
+USERS= ${PORTNAME}
+GROUPS= ${PORTNAME}
+
post-build:
${SED} 's|%%PREFIX%%|${PREFIX}|g ; s|%%RC_SUBR%%|/etc/rc.subr|g' \
${WRKSRC}/freebsd/rtpproxy.in > ${WRKDIR}/rtpproxy
-pre-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/rtpproxy ${PREFIX}/etc/rc.d/rtpproxy
diff --git a/net/rtpproxy/pkg-install b/net/rtpproxy/pkg-install
deleted file mode 100644
index 58954e7a3963..000000000000
--- a/net/rtpproxy/pkg-install
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-#
-
-if [ "$2" != "PRE-INSTALL" ]; then
- exit 0
-fi
-
-RTPPROXY_USER=rtpproxy
-RTPPROXY_GROUP=${RTPPROXY_USER}
-RTPPROXY_UID=222
-RTPPROXY_GID=${RTPPROXY_UID}
-
-if ! pw groupshow "${RTPPROXY_GROUP}" 2>/dev/null 1>&2; then
- if pw groupadd ${RTPPROXY_GROUP} -g ${RTPPROXY_GID}; then
- echo "Added group \"${RTPPROXY_GROUP}\"."
- else
- echo "Adding group \"${RTPPROXY_GROUP}\" failed..."
- exit 1
- fi
-fi
-
-if ! pw usershow "${RTPPROXY_USER}" 2>/dev/null 1>&2; then
- if pw useradd ${RTPPROXY_USER} -u ${RTPPROXY_UID} -g ${RTPPROXY_GROUP} -h - \
- -s "/sbin/nologin" -d "/nonexistent" \
- -c "RTP Proxy"; \
- then
- echo "Added user \"${RTPPROXY_USER}\"."
- else
- echo "Adding user \"${RTPPROXY_USER}\" failed..."
- exit 1
- fi
-fi
-
-exit 0