aboutsummaryrefslogtreecommitdiff
path: root/net/ruby-ldap/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-24 19:40:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-24 19:40:38 +0000
commita10318dfa488cedfb4ee20682dc7cb11f6a3914b (patch)
tree6122ad643f783757da95e5a132693c3f918979ba /net/ruby-ldap/Makefile
parent0187e86785f52db7a61db937e2426edebdfade73 (diff)
downloadports-a10318dfa488cedfb4ee20682dc7cb11f6a3914b.tar.gz
ports-a10318dfa488cedfb4ee20682dc7cb11f6a3914b.zip
Notes
Diffstat (limited to 'net/ruby-ldap/Makefile')
-rw-r--r--net/ruby-ldap/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/net/ruby-ldap/Makefile b/net/ruby-ldap/Makefile
new file mode 100644
index 000000000000..b48e4918befa
--- /dev/null
+++ b/net/ruby-ldap/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: Ruby/LDAP
+# Date created: 25 Sep 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldap
+PORTVERSION= 0.1
+CATEGORIES= net ruby
+MASTER_SITES= http://kt-www.jaist.ac.jp:8000/~ttate/ftp/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+.if !defined(WITHOUT_OPENLDAP1)
+LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
+.endif
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
+
+# Configure options:
+# --with-ldap specify the ldap directory
+# --with-ldap-incdir specify the directory which contains ldap.h and lber.h
+# --with-ldap-libdir specify the directory which contains ldap libraries
+# --with-netscape specify this to use Netscape SDK
+# --with-openldap1 specify this to use OpenLDAP-1.x
+# --with-openldap2 specify this to use OpenLDAP-2.x
+CONFIGURE_ARGS?= --with-openldap1 --with-ldap="${LOCALBASE}"
+
+INSTALL_TARGET= site-install
+
+DOCS_EN= README README.html
+EXAMPLES_EN= test1.rb test2.rb test3.rb test4.rb \
+ test5.rb test6.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/ldap
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/test/${f} ${RUBY_EXAMPLESDIR}/ldap/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/ldap
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/ldap/
+.endfor
+.endif
+
+.include <bsd.port.mk>