aboutsummaryrefslogtreecommitdiff
path: root/net/ruby-romp/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-24 07:06:19 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-24 07:06:19 +0000
commit80814c743bfaaff1d5edab81c2ffc30b09cfd133 (patch)
treef2b5f0b7781bfe7d78f5c2ea871091cc58a608d8 /net/ruby-romp/Makefile
parent13273b7d099f7ef24c92350355484378773cd019 (diff)
downloadports-80814c743bfaaff1d5edab81c2ffc30b09cfd133.tar.gz
ports-80814c743bfaaff1d5edab81c2ffc30b09cfd133.zip
Notes
Diffstat (limited to 'net/ruby-romp/Makefile')
-rw-r--r--net/ruby-romp/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/net/ruby-romp/Makefile b/net/ruby-romp/Makefile
new file mode 100644
index 000000000000..4288ff2e0dfc
--- /dev/null
+++ b/net/ruby-romp/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ROMP
+# Date created: 24 August 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= romp
+PORTVERSION= 0.1
+CATEGORIES= net ruby
+MASTER_SITES= http://rm-f.net/~cout/ruby/romp/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} romp.html
+DIST_SUBDIR= ruby
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= knu@FreeBSD.org
+
+IGNOREFILES= romp.html
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+EXAMPLES= client.rb server.rb
+DOCS= romp.html
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/lib
+.for f in druby4.rb romp.rb
+ ${MV} ${WRKSRC}/${f} ${WRKSRC}/lib/
+.endfor
+ ${CP} ${_DISTDIR}/romp.html ${WRKSRC}/
+
+post-patch:
+ ${RUBY} -i~ -pe 'sub /^(#include\s*<stdint\.h>)/, "/*\\1*/"' ${WRKSRC}/*.c
+ ${RUBY} -i~ -pe 'sub /(.*CFLAGS)/, "#\\1/"' ${WRKSRC}/extconf.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>