aboutsummaryrefslogtreecommitdiff
path: root/net/ruby-tcpsocketpipe
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-07-19 19:06:03 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-07-19 19:06:03 +0000
commit6bf1507aad2c2ecc8e7797c7f3b1584b16855b46 (patch)
tree23cfda9d2165cf04b59e81bd921cfaddc6f71c17 /net/ruby-tcpsocketpipe
parent19b42c1e982d282e3ff65d8505ea5fcc939f0e64 (diff)
downloadports-6bf1507aad2c2ecc8e7797c7f3b1584b16855b46.tar.gz
ports-6bf1507aad2c2ecc8e7797c7f3b1584b16855b46.zip
Notes
Diffstat (limited to 'net/ruby-tcpsocketpipe')
-rw-r--r--net/ruby-tcpsocketpipe/Makefile32
-rw-r--r--net/ruby-tcpsocketpipe/distinfo1
-rw-r--r--net/ruby-tcpsocketpipe/pkg-comment1
-rw-r--r--net/ruby-tcpsocketpipe/pkg-descr5
-rw-r--r--net/ruby-tcpsocketpipe/pkg-plist3
5 files changed, 42 insertions, 0 deletions
diff --git a/net/ruby-tcpsocketpipe/Makefile b/net/ruby-tcpsocketpipe/Makefile
new file mode 100644
index 000000000000..a6810dea84d6
--- /dev/null
+++ b/net/ruby-tcpsocketpipe/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Ruby/TCPSocketPipe
+# Date created: 20 July 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpsocketpipe
+PORTVERSION= 1.8
+CATEGORIES= net ruby
+MASTER_SITES= http://www.jin.gr.jp/~nahi/Ruby/TCPSocketPipe/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= TCPSocketPipe-${PORTVERSION:S/./_/g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/application.rb:${PORTSDIR}/sysutils/ruby-application.rb \
+ ${RUBY_SITELIBDIR}/dump.rb:${PORTSDIR}/converters/ruby-dump.rb
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/TCPSocketPipe.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/monitor.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ruby-tcpsocketpipe/distinfo b/net/ruby-tcpsocketpipe/distinfo
new file mode 100644
index 000000000000..10a2351512e8
--- /dev/null
+++ b/net/ruby-tcpsocketpipe/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/TCPSocketPipe-1_8.tar.gz) = 85f67daf99423abf0562ecd88904216c
diff --git a/net/ruby-tcpsocketpipe/pkg-comment b/net/ruby-tcpsocketpipe/pkg-comment
new file mode 100644
index 000000000000..78f027c4321a
--- /dev/null
+++ b/net/ruby-tcpsocketpipe/pkg-comment
@@ -0,0 +1 @@
+A Ruby library to create I/O pipes for TCP socket tunneling
diff --git a/net/ruby-tcpsocketpipe/pkg-descr b/net/ruby-tcpsocketpipe/pkg-descr
new file mode 100644
index 000000000000..f980208efe0d
--- /dev/null
+++ b/net/ruby-tcpsocketpipe/pkg-descr
@@ -0,0 +1,5 @@
+This is Ruby/TCPSocketPipe, a Ruby library to create I/O pipes for TCP
+socket tunneling.
+
+Author: NaHi (NAKAMURA, Hiroshi) <nahi@keynauts.com>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=TCPSocketPipe
diff --git a/net/ruby-tcpsocketpipe/pkg-plist b/net/ruby-tcpsocketpipe/pkg-plist
new file mode 100644
index 000000000000..d7e8025f34a5
--- /dev/null
+++ b/net/ruby-tcpsocketpipe/pkg-plist
@@ -0,0 +1,3 @@
+%%RUBY_SITELIBDIR%%/TCPSocketPipe.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/tcpsocketpipe/monitor.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/tcpsocketpipe