aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-bunny060
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-07-02 02:13:49 +0000
committerSteve Wills <swills@FreeBSD.org>2013-07-02 02:13:49 +0000
commit67872541abe5199627d9cd48d10551222e308b2e (patch)
treeb3d0922cde8b57d841b31799f3df41274da858a9 /net/rubygem-bunny060
parent63a1be3d621fc214f61c30c5b0cf3c14711bbc55 (diff)
downloadports-67872541abe5199627d9cd48d10551222e308b2e.tar.gz
ports-67872541abe5199627d9cd48d10551222e308b2e.zip
Notes
Diffstat (limited to 'net/rubygem-bunny060')
-rw-r--r--net/rubygem-bunny060/Makefile20
-rw-r--r--net/rubygem-bunny060/distinfo2
-rw-r--r--net/rubygem-bunny060/pkg-descr16
3 files changed, 38 insertions, 0 deletions
diff --git a/net/rubygem-bunny060/Makefile b/net/rubygem-bunny060/Makefile
new file mode 100644
index 000000000000..356ee753feb0
--- /dev/null
+++ b/net/rubygem-bunny060/Makefile
@@ -0,0 +1,20 @@
+# Ports collection makefile for: rubygem-bunny
+# Date created: 19 Mar 2010
+# Whom: renchap@cocoa-x.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= bunny
+PORTVERSION= 0.6.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= renchap@cocoa-x.com
+COMMENT= Another synchronous Ruby AMQP client
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-bunny060/distinfo b/net/rubygem-bunny060/distinfo
new file mode 100644
index 000000000000..3d13d521e03c
--- /dev/null
+++ b/net/rubygem-bunny060/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/bunny-0.6.0.gem) = fb8142488e96124f1b880979d1006366f254323f555add01a028ef70db306038
+SIZE (rubygem/bunny-0.6.0.gem) = 32256
diff --git a/net/rubygem-bunny060/pkg-descr b/net/rubygem-bunny060/pkg-descr
new file mode 100644
index 000000000000..21ad3f2be176
--- /dev/null
+++ b/net/rubygem-bunny060/pkg-descr
@@ -0,0 +1,16 @@
+Bunny is an AMQP (Advanced Message Queuing Protocol) client, written in Ruby,
+that is intended to allow you to interact with AMQP-compliant message
+brokers/servers such as RabbitMQ in a synchronous fashion.
+
+It is based on a great deal of useful code from amqp by Aman Gupta and Carrot
+by Amos Elliston.
+
+You can use Bunny to :
+* Create and delete exchanges
+* Create and delete queues
+* Publish and consume messages
+
+Bunny is known to work with RabbitMQ versions 1.5.4 and above with version 0-8
+of the AMQP specification.
+
+WWW: https://github.com/ruby-amqp/bunny