aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-oauth2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-29 03:59:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-29 03:59:21 +0000
commitd29b20b2365227b80989c7f50527c0911abcbfe3 (patch)
treea046568f8ff0ddf4c6a6089e370e9ecc48bb9b5d /net/rubygem-oauth2
parent350d53b4ed9d2e85318c9cbc66f5cf74700eb294 (diff)
downloadports-d29b20b2365227b80989c7f50527c0911abcbfe3.tar.gz
ports-d29b20b2365227b80989c7f50527c0911abcbfe3.zip
Notes
Diffstat (limited to 'net/rubygem-oauth2')
-rw-r--r--net/rubygem-oauth2/Makefile23
-rw-r--r--net/rubygem-oauth2/distinfo2
-rw-r--r--net/rubygem-oauth2/pkg-descr7
3 files changed, 32 insertions, 0 deletions
diff --git a/net/rubygem-oauth2/Makefile b/net/rubygem-oauth2/Makefile
new file mode 100644
index 000000000000..33f7d2db5039
--- /dev/null
+++ b/net/rubygem-oauth2/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: rubygem-oauth2
+# Date created: 2011-10-18
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oauth2
+PORTVERSION= 0.5.1
+CATEGORIES= net ruby
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A Ruby wrapper for the OAuth 2.0 protocol
+
+RUN_DEPENDS= rubygem-faraday>=0.7.4:${PORTSDIR}/www/rubygem-faraday \
+ rubygem-multi_json>=1.0.3:${PORTSDIR}/devel/rubygem-multi_json
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-oauth2/distinfo b/net/rubygem-oauth2/distinfo
new file mode 100644
index 000000000000..176dca657acc
--- /dev/null
+++ b/net/rubygem-oauth2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/oauth2-0.5.1.gem) = b823e97ff0f49b6b1fe90d7068b14a1edb2802761f2c04f960ada2401518fe14
+SIZE (rubygem/oauth2-0.5.1.gem) = 15872
diff --git a/net/rubygem-oauth2/pkg-descr b/net/rubygem-oauth2/pkg-descr
new file mode 100644
index 000000000000..61505d5feec9
--- /dev/null
+++ b/net/rubygem-oauth2/pkg-descr
@@ -0,0 +1,7 @@
+OAuth2 is a Ruby wrapper for the OAuth 2.0 specification. This is a work in
+progress, being built first to solve the pragmatic process of connecting to
+existing OAuth 2.0 endpoints (a.k.a. Facebook) with the goal of building it up
+to meet the entire specification over time.
+
+WWW: https://github.com/intridea/oauth2
+WWW: https://rubygems.org/gems/oauth2