aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-righthttpconnection
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-05-02 02:57:46 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-05-02 02:57:46 +0000
commitab4d6026d307bfd232d311523e3855accf95ee6d (patch)
treea69346e5b9f7c5eb0ed77a9e87db5960511eb8aa /net/rubygem-righthttpconnection
parentf0d8f88d061113a821500d201c6ba38a26a236f4 (diff)
downloadports-ab4d6026d307bfd232d311523e3855accf95ee6d.tar.gz
ports-ab4d6026d307bfd232d311523e3855accf95ee6d.zip
Notes
Diffstat (limited to 'net/rubygem-righthttpconnection')
-rw-r--r--net/rubygem-righthttpconnection/Makefile22
-rw-r--r--net/rubygem-righthttpconnection/distinfo3
-rw-r--r--net/rubygem-righthttpconnection/pkg-descr7
-rw-r--r--net/rubygem-righthttpconnection/pkg-plist50
4 files changed, 82 insertions, 0 deletions
diff --git a/net/rubygem-righthttpconnection/Makefile b/net/rubygem-righthttpconnection/Makefile
new file mode 100644
index 000000000000..3a7454500005
--- /dev/null
+++ b/net/rubygem-righthttpconnection/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: rubygem-righthttpconnection
+# Date created: 01 May 2008
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= righthttpconnection
+PORTVERSION= 1.2.1
+CATEGORIES= net rubygems
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= rightaws
+DISTNAME= right_http_connection-${PORTVERSION}
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= Persistent HTTP/HTTPS connections with error retries
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+GEM_NAME= ${DISTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-righthttpconnection/distinfo b/net/rubygem-righthttpconnection/distinfo
new file mode 100644
index 000000000000..f6b5ebc91413
--- /dev/null
+++ b/net/rubygem-righthttpconnection/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/right_http_connection-1.2.1.gem) = 65a15eee27aa765219756a99a4198f57
+SHA256 (rubygem/right_http_connection-1.2.1.gem) = 2fe4c2c75345e4c93d19f4405eafb4198c8b7eee2c4090471d22a253a53753ca
+SIZE (rubygem/right_http_connection-1.2.1.gem) = 21504
diff --git a/net/rubygem-righthttpconnection/pkg-descr b/net/rubygem-righthttpconnection/pkg-descr
new file mode 100644
index 000000000000..7524980f319b
--- /dev/null
+++ b/net/rubygem-righthttpconnection/pkg-descr
@@ -0,0 +1,7 @@
+RightScale's AWS gems provide robust, fast, and secure Ruby interfaces
+to Amazon EC2, Amazon S3, Amazon SQS, and Amazon SDB. The gems use
+Amazon's REST and query interfaces to provide full programmatic
+control. An optional robust HTTP layer retries and clears transient
+errors.
+
+WWW: http://rightaws.rubyforge.org/
diff --git a/net/rubygem-righthttpconnection/pkg-plist b/net/rubygem-righthttpconnection/pkg-plist
new file mode 100644
index 000000000000..bb2c306c4f89
--- /dev/null
+++ b/net/rubygem-righthttpconnection/pkg-plist
@@ -0,0 +1,50 @@
+%%GEM_CACHE%%
+%%GEM_DOC_DIR%%/rdoc/classes/Net.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/HTTP.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/HTTP.src/M000013.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/HTTPGenericRequest.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/HTTPGenericRequest.src/M000011.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/HTTPGenericRequest.src/M000012.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000001.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000002.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000003.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000004.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000005.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000006.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000007.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000008.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000009.html
+%%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src/M000010.html
+%%GEM_DOC_DIR%%/rdoc/created.rid
+%%GEM_DOC_DIR%%/rdoc/files/History_txt.html
+%%GEM_DOC_DIR%%/rdoc/files/Manifest_txt.html
+%%GEM_DOC_DIR%%/rdoc/files/README_txt.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/net_fix_rb.html
+%%GEM_DOC_DIR%%/rdoc/files/lib/right_http_connection_rb.html
+%%GEM_DOC_DIR%%/rdoc/fr_class_index.html
+%%GEM_DOC_DIR%%/rdoc/fr_file_index.html
+%%GEM_DOC_DIR%%/rdoc/fr_method_index.html
+%%GEM_DOC_DIR%%/rdoc/index.html
+%%GEM_DOC_DIR%%/rdoc/rdoc-style.css
+%%GEM_LIB_DIR%%/History.txt
+%%GEM_LIB_DIR%%/Manifest.txt
+%%GEM_LIB_DIR%%/README.txt
+%%GEM_LIB_DIR%%/Rakefile
+%%GEM_LIB_DIR%%/lib/net_fix.rb
+%%GEM_LIB_DIR%%/lib/right_http_connection.rb
+%%GEM_LIB_DIR%%/setup.rb
+%%GEM_SPEC%%
+@dirrm %%GEM_LIB_DIR%%/lib
+@dirrm %%GEM_LIB_DIR%%
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib
+@dirrm %%GEM_DOC_DIR%%/rdoc/files
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Rightscale/HttpConnection.src
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Rightscale
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Net/HTTPGenericRequest.src
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Net/HTTP.src
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Net
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes
+@dirrm %%GEM_DOC_DIR%%/rdoc
+@dirrm %%GEM_DOC_DIR%%