aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-tweetstream
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2010-11-23 00:12:21 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2010-11-23 00:12:21 +0000
commitc5f8c5a2ce4249c9e7f4bf08bf5799ac02f88767 (patch)
tree352e643b48e977786ca83a2769e4544d417ea0f6 /net/rubygem-tweetstream
parent66828f0bdf5dd7570eca26609f0cb73110a762b5 (diff)
- Add a new port: net/rubygem-tweetstream
TweetStream provides simple Ruby access to Twitter's Streaming API WWW: http://github.com/intridea/tweetstream
Notes
Notes: svn path=/head/; revision=264952
Diffstat (limited to 'net/rubygem-tweetstream')
-rw-r--r--net/rubygem-tweetstream/Makefile42
-rw-r--r--net/rubygem-tweetstream/distinfo2
-rw-r--r--net/rubygem-tweetstream/pkg-descr3
3 files changed, 47 insertions, 0 deletions
diff --git a/net/rubygem-tweetstream/Makefile b/net/rubygem-tweetstream/Makefile
new file mode 100644
index 000000000000..7423cf93abc5
--- /dev/null
+++ b/net/rubygem-tweetstream/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: rubygem-tweetstream
+# Date created: 2010-11-17
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tweetstream
+PORTVERSION= 1.0.4
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= TweetStream provides simple Ruby access to Twitter\'s Streaming API
+
+RUN_DEPENDS= rubygem-twitter-stream>=0.0:${PORTSDIR}/net/rubygem-twitter-stream \
+ rubygem-daemons>=0.0.0:${PORTSDIR}/devel/rubygem-daemons \
+ rubygem-json>=0.0.0:${PORTSDIR}/devel/rubygem-json
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+OPTIONS= JSON_PURE "JSON implementation in pure Ruby support" Off \
+ ACTIVESUPPORT "ActiveSupport::JSON.decode support" Off \
+ YAJL_RUBY "yajl-ruby support" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_JSON_PURE)
+RUN_DEPENDS+= rubygem-json_pure>=0:${PORTSDIR}/devel/rubygem-json_pure
+.endif
+
+.if defined(WITH_ACTIVESUPPORT)
+RUN_DEPENDS+= rubygem-activesupport>=0:${PORTSDIR}/devel/rubygem-activesupport
+.endif
+
+.if defined(WITH_YAJL_RUBY)
+RUN_DEPENDS+= rubygem-yajl-ruby>=0:${PORTSDIR}/devel/rubygem-yajl-ruby
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-tweetstream/distinfo b/net/rubygem-tweetstream/distinfo
new file mode 100644
index 000000000000..7a3f013ae4a5
--- /dev/null
+++ b/net/rubygem-tweetstream/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/tweetstream-1.0.4.gem) = 902c65135f7e3da245137353261ff9b4469b753ca8564a7eb1221b04d82ac231
+SIZE (rubygem/tweetstream-1.0.4.gem) = 15360
diff --git a/net/rubygem-tweetstream/pkg-descr b/net/rubygem-tweetstream/pkg-descr
new file mode 100644
index 000000000000..85351387b303
--- /dev/null
+++ b/net/rubygem-tweetstream/pkg-descr
@@ -0,0 +1,3 @@
+TweetStream provides simple Ruby access to Twitter's Streaming API
+
+WWW: http://github.com/intridea/tweetstream