aboutsummaryrefslogtreecommitdiff
path: root/net/samba-libsmbclient
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-09 20:34:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-09 20:34:40 +0000
commit862b7eb349ac65efcd842b1ccaa54c6202337509 (patch)
treefc0548e3549ea7d04520ddfae27bda2c3fee5286 /net/samba-libsmbclient
parent1340b882588bb9f9075614a202e7b7ea308d3502 (diff)
downloadports-862b7eb349ac65efcd842b1ccaa54c6202337509.tar.gz
ports-862b7eb349ac65efcd842b1ccaa54c6202337509.zip
Notes
Diffstat (limited to 'net/samba-libsmbclient')
-rw-r--r--net/samba-libsmbclient/Makefile22
-rw-r--r--net/samba-libsmbclient/pkg-descr4
-rw-r--r--net/samba-libsmbclient/pkg-plist7
3 files changed, 21 insertions, 12 deletions
diff --git a/net/samba-libsmbclient/Makefile b/net/samba-libsmbclient/Makefile
index 57a7d9911716..4b9b39c641b9 100644
--- a/net/samba-libsmbclient/Makefile
+++ b/net/samba-libsmbclient/Makefile
@@ -12,38 +12,40 @@ PKGNAMESUFFIX= -libsmbclient
MAINTAINER= kwm@rainbow-runner.nl
COMMENT= The shared lib from the samba packages
-CONFLICTS= samba-3.*
-
-USE_ICONV= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+CONFLICTS=
SAMBA_PORT= samba-devel
SAMBA_SUBPORT= yes
MASTERDIR= ${.CURDIR}/../${SAMBA_PORT}
PKGDIR= ${.CURDIR}
+
+INSTALLS_SHLIB= yes
+
# We WANT libsmbclient support :)
CONFIGURE_ARGS+= --with-libsmbclient
-CONFIGURE_ARGS+= --with-libiconv
# This is taken from SAMBA_PORT(grep without)
+CONFIGURE_ARGS+= --disable-cups
CONFIGURE_ARGS+= --without-python
+CONFIGURE_ARGS+= --without-syslog
+CONFIGURE_ARGS+= --without-quotas
CONFIGURE_ARGS+= --without-utmp
CONFIGURE_ARGS+= --without-winbind
-CONFIGURE_ARGS+= --without-ads
-CONFIGURE_ARGS+= --without-ldap
CONFIGURE_ARGS+= --without-ldapsam
-CONFIGURE_ARGS+= --without-krb5
CONFIGURE_ARGS+= --without-pam_smbpass
do-build:
- cd ${WRKSRC} && ${MAKE} include/proto.h
+ cd ${WRKSRC} && ${MAKE} proto
cd ${WRKSRC} && ${MAKE} libsmbclient
do-install:
+ -@${MKDIR} ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/include/libsmbclient.h ${PREFIX}/include
+ -@${MKDIR} ${PREFIX}/lib
${INSTALL_SCRIPT} ${WRKSRC}/bin/libsmbclient.a ${PREFIX}/lib
${INSTALL_SCRIPT} ${WRKSRC}/bin/libsmbclient.so.0 ${PREFIX}/lib
${LN} -snf libsmbclient.so.0 ${PREFIX}/lib/libsmbclient.so
+ -@${MKDIR} ${EXAMPLESDIR}
+ @${CP} -Rp ${WRKDIR}/${DISTNAME}/examples/libsmbclient/* ${EXAMPLESDIR}
.include "${MASTERDIR}/Makefile"
diff --git a/net/samba-libsmbclient/pkg-descr b/net/samba-libsmbclient/pkg-descr
index ba7730bd62d1..4a808dcf47b2 100644
--- a/net/samba-libsmbclient/pkg-descr
+++ b/net/samba-libsmbclient/pkg-descr
@@ -1,4 +1,4 @@
-This is the shared library from the Samba program. It lets other programs use
-the SMB protocol.
+This is the shared library from the Samba port. It lets other programs
+to use the SMB protocol.
WWW: http://www.samba.org/
diff --git a/net/samba-libsmbclient/pkg-plist b/net/samba-libsmbclient/pkg-plist
index 910dd705c206..73fa367852c8 100644
--- a/net/samba-libsmbclient/pkg-plist
+++ b/net/samba-libsmbclient/pkg-plist
@@ -2,3 +2,10 @@ include/libsmbclient.h
lib/libsmbclient.a
lib/libsmbclient.so
lib/libsmbclient.so.0
+%%EXAMPLESDIR%%/Makefile
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/testacl.c
+%%EXAMPLESDIR%%/testbrowse.c
+%%EXAMPLESDIR%%/testsmbc.c
+%%EXAMPLESDIR%%/tree.c
+@dirrm %%EXAMPLESDIR%%