aboutsummaryrefslogtreecommitdiff
path: root/net/samba/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-05-28 21:03:12 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-05-28 21:03:12 +0000
commit4b78078e62b45cb04c304560cbab2ff57113a1bc (patch)
treebb43e2eef4363ea60337cca0e206b49bd51d10d8 /net/samba/Makefile
parent4460cd9753b9da7f18767e8a960005a3e68e3c87 (diff)
Notes
Diffstat (limited to 'net/samba/Makefile')
-rw-r--r--net/samba/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/samba/Makefile b/net/samba/Makefile
index c16de4e3ef41..39178e3aca92 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -19,6 +19,7 @@ MASTER_SITE_SUBDIR= . old-versions old
MAINTAINER= dwcjr@FreeBSD.org
USE_BZIP2= YES
+USE_SUBMAKE= YES
.if defined(WITH_AUDIT) || defined(WITH_RECYCLE)
USE_GMAKE= YES
@@ -39,8 +40,23 @@ LIBSAMBA= ""
.endif
# directories
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+IS_INTERACTIVE= yes
+.endif
+
+.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
+.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.endif
+
VARDIR= /var
SAMBA_SPOOL= ${VARDIR}/spool/samba
+SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ TOUCH="${TOUCH}" \
+ MKDIR="${MKDIR}" \
+ CAT="${CAT}" \
+ SAMBA_OPTIONS="${SAMBA_OPTIONS}" \
+ REALCURDIR="${.CURDIR}"
+
SAMBA_LOGDIR= ${VARDIR}/log
SAMBA_PRIVATE= ${PREFIX}/private
SAMBA_CONFDIR= ${PREFIX}/etc
@@ -91,6 +107,12 @@ CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
WITH_CUPS= yes
.endif
+pre-fetch:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.samba
+
+post-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
+
.if defined(WITH_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \