aboutsummaryrefslogtreecommitdiff
path: root/net/samba3/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-02-07 05:15:17 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-02-07 05:15:17 +0000
commit22f2d61c80eb645e83c664efade5762cf5dfb0e8 (patch)
treeb771cb756ef33bd37eb28d595c82f09dfeaf1178 /net/samba3/Makefile
parent91025526aa5b0041781bdb0e86125d0e5686f2b7 (diff)
downloadports-22f2d61c80eb645e83c664efade5762cf5dfb0e8.tar.gz
ports-22f2d61c80eb645e83c664efade5762cf5dfb0e8.zip
Notes
Diffstat (limited to 'net/samba3/Makefile')
-rw-r--r--net/samba3/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index fdfe52ba9214..3c23e4204806 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= samba
-PORTVERSION= 3.0.10
+PORTVERSION?= 3.0.11
PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES?= net
@@ -43,7 +43,7 @@ SAMBA_CONFIG= ${SAMBA_CONFDIR}/smb.conf
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
--localstatedir=${VARDIR} \
@@ -205,13 +205,6 @@ LIB_DEPENDS+= popt.0:${PORTSDIR}/devel/popt
CONFIGURE_ARGS+= --with-included-popt
.endif
-.if defined(WITH_MULTIBYTE)
-# Based on patch from miraclelinux.com.
-# http://www.miraclelinux.com/english/technet/samba30/index.html
-PLIST_SUB+= MULTIBYTE=""
-.else
-PLIST_SUB+= MULTIBYTE="@comment "
-.endif
# !SAMBA_SUBPORT
.endif
@@ -281,7 +274,7 @@ RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
SAMBA_LOCKDIR=${SAMBA_LOCKDIR} \
SAMBA_SPOOL=${SAMBA_SPOOL}
-pre-everything::
+pre-configure::
@${ECHO_MSG} ""
@${ECHO_MSG} "!!! Due to a bug in the deinstall procedure in port versions prior to 3.0.9,"
@${ECHO_MSG} "!!! you should BACK UP YOUR VALUABLE ${SAMBA_LOCKDIR}/windbindd_* FILES"
@@ -296,12 +289,15 @@ pre-fetch:
@${ECHO_MSG} "===> -------------------------------------------"
post-patch:
- @${FIND} ${WRKSRC} -name CVS -o -name .cvsignore | ${XARGS} ${RM}
+ @${RM} -rf ${WRKDIR}/${DISTNAME}/examples/LDAP/smbldap-tools-*
@${RM} -rf ${WRKDIR}/${DISTNAME}/examples/libsmbclient
@${RM} -rf ${WRKDIR}/${DISTNAME}/swat/lang
+ @${FIND} ${WRKSRC} -name CVS -o -name .cvsignore | ${XARGS} ${RM}
+ @${FIND} ${WRKDIR}/${DISTNAME} -type d | ${XARGS} ${CHMOD} 0755
+ @${FIND} ${WRKDIR}/${DISTNAME}/examples -type f | ${XARGS} ${CHMOD} 0644
pre-install:
- @${FIND} ${SAMBA_LIBDIR} -type f | ${SORT} | ${SED} -e 's|^${PREFIX}||; s|^/||' >> ${WRKDIR}/.PLIST.exclude
+ -@${FIND} ${SAMBA_LIBDIR} -type f 2>/dev/null | ${SORT} | ${SED} -e 's|^${PREFIX}||; s|^/||' >> ${WRKDIR}/.PLIST.exclude
post-install:
.for sect in 1 5 7 8