aboutsummaryrefslogtreecommitdiff
path: root/net/samba3
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-17 16:10:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-17 16:10:50 +0000
commitbc110054fdb8cb1555e433583230a4903e02aa19 (patch)
tree0bf75ba85cb1781352a0a9f24048dfec7ac0896b /net/samba3
parent8de16c7c50a7131e3370d3c37c06568f5fe4c556 (diff)
downloadports-bc110054fdb8cb1555e433583230a4903e02aa19.tar.gz
ports-bc110054fdb8cb1555e433583230a4903e02aa19.zip
Notes
Diffstat (limited to 'net/samba3')
-rw-r--r--net/samba3/Makefile20
-rw-r--r--net/samba3/distinfo4
-rw-r--r--net/samba3/files/patch-smbd_dir.c20
-rw-r--r--net/samba3/files/samba.sh.sample7
4 files changed, 10 insertions, 41 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 56b950c24abf..213b38b2e7db 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= samba
-PORTVERSION?= 3.0.12
-PORTREVISION?= 1
+PORTVERSION?= 3.0.14a
+PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
@@ -93,7 +93,7 @@ USE_RC_SUBR= yes
CONFIGURE_ARGS+= --with-pam --with-readline --with-sendfile-support \
--without-libsmbclient --without-python
-.if defined(WITH_CUPS)
+.if !defined(WITHOUT_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
CONFIGURE_ARGS+= --enable-cups
CUPS= cups
@@ -216,7 +216,7 @@ CONFIGURE_ARGS+= --with-included-popt
.endif
# Common part
-.if defined(WITH_ADS)
+.if !defined(WITHOUT_ADS)
WANT_LDAP= yes
WANT_KRB5= yes
CONFIGURE_ARGS+= --with-ads
@@ -281,15 +281,6 @@ RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
SAMBA_LOCKDIR=${SAMBA_LOCKDIR} \
SAMBA_SPOOL=${SAMBA_SPOOL}
-pre-configure::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "!!! Due to a bug in the deinstall procedure in port versions prior to 3.0.9,"
- @${ECHO_MSG} "!!! you should BACK UP YOUR VALUABLE ${SAMBA_LOCKDIR}/windbindd_* FILES"
- @${ECHO_MSG} "!!! before you continue the (re)installation."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "*** Press Ctrl-C *now* if you need to preserve these files ***"
- @sleep 5
-
pre-fetch:
@${ECHO_MSG} "===> -------------------------------------------"
@${ECHO_MSG} "===> Run 'make config' to (re)configure the port"
@@ -362,8 +353,7 @@ post-install:
@${ECHO_CMD} "@exec ${MKDIR} ${SAMBA_LOCKDIR} 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO_CMD} "@exec ${CHMOD} 0755 ${SAMBA_LOCKDIR}" >> ${TMPPLIST}
@${ECHO_CMD} "@exec ${CHOWN} root:wheel ${SAMBA_LOCKDIR}" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ${RM} -rf ${SAMBA_LOCKDIR}/printing" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec for f in \`${LS} ${SAMBA_LOCKDIR} | ${GREP} -v '^winbindd_'\`; do ${RM} -f ${SAMBA_LOCKDIR}/\$${f}; done" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec for f in connections.tdb locking.tdb messages.tdb sessionid.tdb unexpected.tdb brlock.tdb namelist.debug; do ${RM} -f ${SAMBA_LOCKDIR}/\$${f}; done" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} ${SAMBA_LOCKDIR} 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${ECHO_CMD} \"Warning: If you will *NOT* use this package anymore, please remove ${SAMBA_LOCKDIR}/* manually.\"" >> ${TMPPLIST}
# Private
diff --git a/net/samba3/distinfo b/net/samba3/distinfo
index 267e1be389ff..715a03ed9209 100644
--- a/net/samba3/distinfo
+++ b/net/samba3/distinfo
@@ -1,2 +1,2 @@
-MD5 (samba-3.0.12.tar.gz) = 5c31e5d115ba08b30d1541983d30e2dc
-SIZE (samba-3.0.12.tar.gz) = 15576905
+MD5 (samba-3.0.14a.tar.gz) = ebee37e66a8b5f6fd328967dc09088e8
+SIZE (samba-3.0.14a.tar.gz) = 15605851
diff --git a/net/samba3/files/patch-smbd_dir.c b/net/samba3/files/patch-smbd_dir.c
deleted file mode 100644
index e7a7a87ec83b..000000000000
--- a/net/samba3/files/patch-smbd_dir.c
+++ /dev/null
@@ -1,20 +0,0 @@
-##
-## See https://bugzilla.samba.org/bug/2501 for details
-##
-diff -urBb --exclude-from=samba-cvs/diff.excludes samba-3.0.12-orig/source/smbd/dir.c samba-3.0.12/source/smbd/dir.c
---- smbd/dir.c.orig 2005-03-18 08:56:41.000000000 -0600
-+++ smbd/dir.c 2005-03-21 12:51:56.541216536 -0600
-@@ -595,6 +595,13 @@
- BOOL dptr_SearchDir(struct dptr_struct *dptr, const char *name, long *poffset, SMB_STRUCT_STAT *pst)
- {
- ZERO_STRUCTP(pst);
-+
-+ if (!dptr->has_wild && (dptr->dir_hnd->offset == -1)) {
-+ /* This is a singleton directory and we're already at the end. */
-+ *poffset = -1;
-+ return False;
-+ }
-+
- while (SearchDir(dptr->dir_hnd, name, poffset) == True) {
- if (is_visible_file(dptr->conn, dptr->path, name, pst, True)) {
- return True;
diff --git a/net/samba3/files/samba.sh.sample b/net/samba3/files/samba.sh.sample
index 15476b31d399..9c154b130fab 100644
--- a/net/samba3/files/samba.sh.sample
+++ b/net/samba3/files/samba.sh.sample
@@ -18,6 +18,7 @@
#
#nmbd_enable="YES"
#smbd_enable="YES"
+%%WINBIND%%# You need to enable winbindd separately, by adding:
%%WINBIND%%#winbindd_enable="YES"
#
@@ -41,11 +42,9 @@ fi
if test -n ${samba_enable:-""} && checkyesno samba_enable; then
nmbd_enable=${nmbd_enable:-"YES"}
smbd_enable=${smbd_enable:-"YES"}
-%%WINBIND%% winbindd_enable=${winbindd_enable:-"YES"}
%%WINBIND%% # Check, that winbind is actally configured
-%%WINBIND%% if [ ! "`egrep -i '(idmap.*uid|winbind.*uid)' ${samba_config} 2>/dev/null | egrep -v [\#\;]`" ]; then
-%%WINBIND%% #warn "Winbind support is not configured"
-%%WINBIND%% winbindd_enable="NO"
+%%WINBIND%% if [ "`egrep -i '(idmap.*uid|winbind.*uid)' ${samba_config} 2>/dev/null | egrep -v [\#\;]`" ]; then
+%%WINBIND%% winbindd_enable="YES"
%%WINBIND%% fi
fi