aboutsummaryrefslogtreecommitdiff
path: root/net/samba3
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-04-12 16:45:41 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-04-12 16:45:41 +0000
commit3ee4f057d0e1de3cec845cfe975d1dbf36c72cdc (patch)
tree15e3f61ecc4b3c573809d78bb8c7a159702acae0 /net/samba3
parentda6f3ec69f90011a6b6154ec2cde204a06ca4a4b (diff)
downloadports-3ee4f057d0e1de3cec845cfe975d1dbf36c72cdc.tar.gz
ports-3ee4f057d0e1de3cec845cfe975d1dbf36c72cdc.zip
Notes
Diffstat (limited to 'net/samba3')
-rw-r--r--net/samba3/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 341bfa23920e..e242fd1bfbbd 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -195,19 +195,20 @@ CONFIGURE_ARGS+= --with-expsam=${WANT_EXPSAM_MODULES}
# Kerberos5 is necessary for ADS
.if defined(WANT_KRB5)
-# Relay on PATH
-KRB5_PREFIX!= krb5-config --prefix
-.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
-CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
-.elif defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME}
.elif ( defined(MAKE_KERBEROS5) || ${OSVERSION} > 500105 ) && exists(/usr/lib/libkrb5.a)
CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr
.else
-#BROKEN= "Kerberos5 is necessary for ADS support. Please, install either Heimdal or MIT-Kerberos"
-LIB_DEPENDS+= krb5.19:${PORTSDIR}/security/heimdal
+BUILD_DEPENDS+= krb5-config:${PORTSDIR}/security/heimdal
+KRB5_PREFIX!= krb5-config --prefix 2>/dev/null || true
+.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
+CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
+.else
+BROKEN= "Kerberos5 is necessary for ADS support. Please, install either Heimdal or MIT-Kerberos"
+.endif
.endif
.else
CONFIGURE_ARGS+= --without-krb5