aboutsummaryrefslogtreecommitdiff
path: root/net/samba3
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-07-20 04:17:44 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-07-20 04:17:44 +0000
commit3712c48039265444fe74e2886e6268fb9eb4dfd2 (patch)
tree6445362658b684372eb7a4d61fedd1528d5d5ad7 /net/samba3
parentc413171b14e2c7080877ff53eab63df2d4a01cbf (diff)
downloadports-3712c48039265444fe74e2886e6268fb9eb4dfd2.tar.gz
ports-3712c48039265444fe74e2886e6268fb9eb4dfd2.zip
Notes
Diffstat (limited to 'net/samba3')
-rw-r--r--net/samba3/Makefile24
-rw-r--r--net/samba3/files/patch-configure.in26
2 files changed, 36 insertions, 14 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 1148b36e4843..44660e1ff253 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= samba
PORTVERSION?= 3.0.14a
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
@@ -60,15 +60,9 @@ CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
.if !defined(SAMBA_SUBPORT)
-OPTIONS= LDAP "With LDAP support" on
-.if defined(PACKAGE_BUILDING)
-# Kerberos5 setup is very box specific, we don't
-# want artificial dependencies in the packages
-OPTIONS+= ADS "With Active Directory support" off
-.else
-OPTIONS+= ADS "With Active Directory support" on
-.endif
-OPTIONS+= CUPS "With CUPS printing support" on \
+OPTIONS= LDAP "With LDAP support" on \
+ ADS "With Active Directory support" off \
+ CUPS "With CUPS printing support" on \
WINBIND "With WinBIND support" on \
ACL_SUPPORT "With ACL support" off \
SYSLOG "With Syslog support" off \
@@ -216,6 +210,16 @@ CONFIGURE_ARGS+= --with-included-popt
.endif
# Common part
+
+# For 4.8 - 4.11 combination of Kerberos and OpenLDAP is broken
+# due the conflict between system and OpenSSL port libcrypto libraries
+.if ${OSVERSION} > 470103 && ${OSVERSION} < 500000
+.if defined(WITH_ADS)
+IGNORE= "Broken dependency between OpenSSL, OpenLDAP and Heimdal for FreeBSD 4.x. Disable ADS support"
+.endif
+WITHOUT_ADS= on
+.endif
+
.if !defined(PACKAGE_BUILDING) && !defined(WITHOUT_ADS)
WANT_LDAP= yes
WANT_KRB5= yes
diff --git a/net/samba3/files/patch-configure.in b/net/samba3/files/patch-configure.in
index 368939ca41bc..264d8495296a 100644
--- a/net/samba3/files/patch-configure.in
+++ b/net/samba3/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig Fri Mar 11 14:47:05 2005
-+++ configure.in Sun Mar 20 01:24:25 2005
-@@ -724,7 +724,9 @@
+--- configure.in.orig Thu Apr 14 08:14:26 2005
++++ configure.in Wed Jul 20 02:42:57 2005
+@@ -727,7 +727,9 @@
AC_CHECK_HEADERS(nss.h nss_common.h nsswitch.h ns_api.h sys/security.h security/pam_appl.h)
AC_CHECK_HEADERS(stropts.h poll.h)
AC_CHECK_HEADERS(sys/capability.h syscall.h sys/syscall.h)
@@ -11,7 +11,7 @@
# These faile to compile on Solaris so just check for their presence
AC_CHECK_HEADERS(security/pam_modules.h net/if.h netinet/ip.h, [], [], -)
-@@ -1159,6 +1161,18 @@
+@@ -1162,6 +1164,18 @@
AC_CHECK_FUNCS(setxattr lsetxattr fsetxattr)
AC_CHECK_FUNCS(attr_get attr_list attr_set attr_remove)
AC_CHECK_FUNCS(attr_getf attr_listf attr_setf attr_removef)
@@ -30,3 +30,21 @@
# Assume non-shared by default and override below
BLDSHARED="false"
+@@ -3974,7 +3988,7 @@
+ AC_DEFINE(HAVE_TRU64_ACLS,1,[Whether Tru64 ACLs are available])
+ ACL_LIBS="$ACL_LIBS -lpacl"
+ ;;
+- *freebsd5*|*freebsd6*)
++ *freebsd[[5-9]]*)
+ AC_MSG_RESULT(Using FreeBSD posix ACLs)
+ AC_DEFINE(HAVE_POSIX_ACLS,1,[Whether FreeBSD POSIX ACLs are available])
+ AC_DEFINE(HAVE_ACL_GET_PERM_NP,1,[Whether acl_get_perm_np() is available])
+@@ -4322,7 +4336,7 @@
+ *linux*)
+ WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_linux.o"
+ ;;
+- *freebsd5*|*freebsd6*)
++ *freebsd[[5-9]]*)
+ # FreeBSD winbind client is implemented as a wrapper around
+ # the Linux version.
+ WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_freebsd.o \