aboutsummaryrefslogtreecommitdiff
path: root/net/samba4/Makefile
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2013-07-09 15:30:00 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2013-07-09 15:30:00 +0000
commit3edadfe24ab4094599acd9338198b025c48537c1 (patch)
tree7f36227ef46bc9bb88bd3c9fe22a0cd0c2af92a2 /net/samba4/Makefile
parentb51534d6b2a488e5324fa5c4323b391a04741833 (diff)
Notes
Diffstat (limited to 'net/samba4/Makefile')
-rw-r--r--net/samba4/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index 57e979a8f29d..333b7167a204 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= ${SAMBA4_PORTNAME}
PORTVERSION?= ${SAMBA4_VERSION}
-PORTREVISION?= 1
+PORTREVISION?= 0
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
MASTER_SITE_SUBDIR= samba/stable samba/rc
@@ -20,7 +20,7 @@ MAKE_JOBS_SAFE= yes
SAMBA4_BASENAME= samba
SAMBA4_PORTNAME= ${SAMBA4_BASENAME}4
-SAMBA4_VERSION= 4.0.4
+SAMBA4_VERSION= 4.0.7
SAMBA4_DISTNAME= ${SAMBA4_BASENAME}-${SAMBA4_VERSION:S|.p|pre|:S|.r|rc|:S|.t|tp|:S|.a|alpha|}
WRKSRC?= ${WRKDIR}/${DISTNAME}
@@ -100,8 +100,8 @@ BUILD_DEPENDS+= talloc>=2.0.8:${PORTSDIR}/devel/talloc
RUN_DEPENDS+= talloc>=2.0.8:${PORTSDIR}/devel/talloc
SAMBA4_BUNDLED_LIBS+= !talloc
# tevent
-BUILD_DEPENDS+= tevent>=0.9.17:${PORTSDIR}/devel/tevent
-RUN_DEPENDS+= tevent>=0.9.17:${PORTSDIR}/devel/tevent
+BUILD_DEPENDS+= tevent>=0.9.18:${PORTSDIR}/devel/tevent
+RUN_DEPENDS+= tevent>=0.9.18:${PORTSDIR}/devel/tevent
SAMBA4_BUNDLED_LIBS+= !tevent
# tdb
BUILD_DEPENDS+= tdb>=1.2.11:${PORTSDIR}/databases/tdb
@@ -271,15 +271,14 @@ CONFIGURE_ARGS+= --with-dnsupdate
CONFIGURE_ARGS+= --without-dnsupdate
.endif
-.if 0
+# https://bugzilla.samba.org/show_bug.cgi?id=9545
.if ${PORT_OPTIONS:MFAM_SUPPORT}
USE_FAM= yes
-CONFIGURE_ARGS+= --enable-fam
+CONFIGURE_ARGS+= --with-fam
WANT_EXP_MODULES+= vfs_notify_fam
SAMBA4_MODULES+= vfs_notify_fam
.else
-CONFIGURE_ARGS+= --disable-fam
-.endif
+CONFIGURE_ARGS+= --without-fam
.endif
.if ${PORT_OPTIONS:MLDAP}