aboutsummaryrefslogtreecommitdiff
path: root/net/samba4wins/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-16 11:24:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-16 11:24:01 +0000
commit6f548616baf53f0f3558ca883dd9c3dd6e2777c8 (patch)
treea56f0fa5ab4d7730306a113b0dc519c518e70bb8 /net/samba4wins/Makefile
parentcae21566ad3f6e5f15f701db6ac61d81816ec00c (diff)
downloadports-6f548616baf53f0f3558ca883dd9c3dd6e2777c8.tar.gz
ports-6f548616baf53f0f3558ca883dd9c3dd6e2777c8.zip
Notes
Diffstat (limited to 'net/samba4wins/Makefile')
-rw-r--r--net/samba4wins/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net/samba4wins/Makefile b/net/samba4wins/Makefile
index 61191a93ca72..63a488fcca5e 100644
--- a/net/samba4wins/Makefile
+++ b/net/samba4wins/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= samba4wins
-PORTVERSION= 1.0.4.r1
+PORTVERSION= 1.0.6
CATEGORIES= net
MASTER_SITES= http://ftp.sernet.de/pub/samba4WINS/debian/pool/
-DISTNAME= ${PORTNAME}_${PORTVERSION:S/.r/-/}
+DISTNAME= ${PORTNAME}_${PORTVERSION}-1
MAINTAINER= timur@gnu.org
COMMENT= A full featured replicating WINS server for UNIX
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
--with-logfilebase=${S4W_LOGDIR}
CONFIGURE_ARGS+= --disable-reg-gconf --disable-socket-wrapper \
- --with-readline=/usr --with-included-popt \
+ --with-readline=${DESTDIR}/usr --with-included-popt \
--with-libiconv=${LOCALBASE} --without-sqlite3 \
--without-pthreads --without-python
@@ -65,11 +65,11 @@ post-build:
post-install:
@${MKDIR} ${S4W_CONFDIR}
${INSTALL_DATA} ${FILESDIR}/samba4wins.conf.sample ${S4W_CONFDIR}
- @${MKDIR} ${DOCSDIR}
.if !defined(NOPORTDOCS)
-.for d in HOWTO.txt NEWS.txt README.txt TODO.txt
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/debian/${PORTNAME}-*-${d} ${DOCSDIR}/${d}
-.endfor
+ @${MKDIR} ${DOCSDIR}
+. for d in HOWTO.txt NEWS.txt README.txt TODO.txt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/debian/${PORTNAME}-${PORTVERSION}-${d} ${DOCSDIR}/${d}
+. endfor
.endif
.include <bsd.port.mk>