aboutsummaryrefslogtreecommitdiff
path: root/net/samba4wins
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-31 18:04:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-31 18:04:20 +0000
commita08eac1dadb840a3d32fb5f9c2b3415dd6032da7 (patch)
treef7572ed74dafc6fb6e5b22529493a3e311ffbbf0 /net/samba4wins
parent54915889e10b369362e4d727359192b3a1e8cfa2 (diff)
downloadports-a08eac1dadb840a3d32fb5f9c2b3415dd6032da7.tar.gz
ports-a08eac1dadb840a3d32fb5f9c2b3415dd6032da7.zip
Notes
Diffstat (limited to 'net/samba4wins')
-rw-r--r--net/samba4wins/Makefile14
-rw-r--r--net/samba4wins/distinfo6
-rw-r--r--net/samba4wins/files/patch-lib_ldb_config.mk56
-rw-r--r--net/samba4wins/files/patch-scripting_ejs_config.mk11
-rw-r--r--net/samba4wins/files/patch-torture_config.mk11
-rw-r--r--net/samba4wins/files/patch-utils_config.mk13
-rw-r--r--net/samba4wins/files/smbd4wins.in (renamed from net/samba4wins/files/smbd4wins.sh.in)2
-rw-r--r--net/samba4wins/pkg-descr6
-rw-r--r--net/samba4wins/pkg-plist31
9 files changed, 122 insertions, 28 deletions
diff --git a/net/samba4wins/Makefile b/net/samba4wins/Makefile
index b374413f2b4c..61191a93ca72 100644
--- a/net/samba4wins/Makefile
+++ b/net/samba4wins/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= samba4wins
-PORTVERSION= 1.0.3.r1
+PORTVERSION= 1.0.4.r1
CATEGORIES= net
MASTER_SITES= http://ftp.sernet.de/pub/samba4WINS/debian/pool/
DISTNAME= ${PORTNAME}_${PORTVERSION:S/.r/-/}
@@ -16,13 +16,15 @@ COMMENT= A full featured replicating WINS server for UNIX
CONFLICTS= ja-samba-2.* ja-samba-4.* samba-2.* samba-4.* sharity-light-1.*
+USE_ICONV= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:259 autoheader:259
WRKSRC= ${WRKDIR}/${PORTNAME}/source
# directories
-VARDIR= ${DESTDIR}/var
+VARDIR?= ${DESTDIR}/var
S4W_DATADIR= ${PREFIX}/share/${PORTNAME}
S4W_LOGDIR= ${VARDIR}/log/${PORTNAME}
S4W_RUNDIR= ${VARDIR}/run
@@ -48,12 +50,18 @@ CONFIGURE_ARGS+= --disable-reg-gconf --disable-socket-wrapper \
--with-libiconv=${LOCALBASE} --without-sqlite3 \
--without-pthreads --without-python
-USE_RC_SUBR= smbd4wins.sh
+USE_RC_SUBR= smbd4wins
SUB_LIST+= S4W_RUNDIR=${S4W_RUNDIR}
PLIST_SUB+= S4W_LOGDIR=${S4W_LOGDIR} \
S4W_LOCKDIR=${S4W_LOCKDIR}
+post-build:
+ @for f in ${WRKSRC}/scripting/bin/*; do \
+ ${REINPLACE_CMD} -i '' -e 's|smbscript|${PREFIX}/bin/smbscript4|' \
+ $${f} && ${MV} $${f} $${f}4; \
+ done
+
post-install:
@${MKDIR} ${S4W_CONFDIR}
${INSTALL_DATA} ${FILESDIR}/samba4wins.conf.sample ${S4W_CONFDIR}
diff --git a/net/samba4wins/distinfo b/net/samba4wins/distinfo
index 73a86d17a34c..b8a490db1bc9 100644
--- a/net/samba4wins/distinfo
+++ b/net/samba4wins/distinfo
@@ -1,3 +1,3 @@
-MD5 (samba4wins_1.0.3-1.tar.gz) = 97d3de004859230c7550ed8858d356ea
-SHA256 (samba4wins_1.0.3-1.tar.gz) = 8613e61093d078de3b1c19de1bc242ded4f6a0502e4b44c5ef9077f1028a9c54
-SIZE (samba4wins_1.0.3-1.tar.gz) = 18788362
+MD5 (samba4wins_1.0.4-1.tar.gz) = 01c4bcc09b63d2da33e199ffc5cccafd
+SHA256 (samba4wins_1.0.4-1.tar.gz) = d5b7eff16a76c0812f6d5389cf5621de3114e9d987ba83e265ce69df7d02c07a
+SIZE (samba4wins_1.0.4-1.tar.gz) = 7230074
diff --git a/net/samba4wins/files/patch-lib_ldb_config.mk b/net/samba4wins/files/patch-lib_ldb_config.mk
new file mode 100644
index 000000000000..3da37cf4981d
--- /dev/null
+++ b/net/samba4wins/files/patch-lib_ldb_config.mk
@@ -0,0 +1,56 @@
+--- lib/ldb/config.mk.orig Mon Aug 28 04:22:54 2006
++++ lib/ldb/config.mk Mon Aug 28 04:23:33 2006
+@@ -179,7 +179,7 @@
+
+ ################################################
+ # Start BINARY ldbadd
+-[BINARY::ldbadd]
++[BINARY::ldbadd4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES = \
+ tools/ldbadd.o
+@@ -191,7 +191,7 @@
+
+ ################################################
+ # Start BINARY ldbdel
+-[BINARY::ldbdel]
++[BINARY::ldbdel4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES= \
+ tools/ldbdel.o
+@@ -203,7 +203,7 @@
+
+ ################################################
+ # Start BINARY ldbmodify
+-[BINARY::ldbmodify]
++[BINARY::ldbmodify4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES= \
+ tools/ldbmodify.o
+@@ -215,7 +215,7 @@
+
+ ################################################
+ # Start BINARY ldbsearch
+-[BINARY::ldbsearch]
++[BINARY::ldbsearch4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES= \
+ tools/ldbsearch.o
+@@ -227,7 +227,7 @@
+
+ ################################################
+ # Start BINARY ldbedit
+-[BINARY::ldbedit]
++[BINARY::ldbedit4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES= \
+ tools/ldbedit.o
+@@ -239,7 +239,7 @@
+
+ ################################################
+ # Start BINARY ldbrename
+-[BINARY::ldbrename]
++[BINARY::ldbrename4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES= \
+ tools/ldbrename.o
diff --git a/net/samba4wins/files/patch-scripting_ejs_config.mk b/net/samba4wins/files/patch-scripting_ejs_config.mk
new file mode 100644
index 000000000000..2d86a5e3083f
--- /dev/null
+++ b/net/samba4wins/files/patch-scripting_ejs_config.mk
@@ -0,0 +1,11 @@
+--- scripting/ejs/config.mk.orig Tue Aug 29 01:37:15 2006
++++ scripting/ejs/config.mk Tue Aug 29 01:37:25 2006
+@@ -37,7 +37,7 @@
+
+ #######################
+ # Start BINARY SMBSCRIPT
+-[BINARY::smbscript]
++[BINARY::smbscript4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES = \
+ smbscript.o
diff --git a/net/samba4wins/files/patch-torture_config.mk b/net/samba4wins/files/patch-torture_config.mk
new file mode 100644
index 000000000000..57bd7f5cd16e
--- /dev/null
+++ b/net/samba4wins/files/patch-torture_config.mk
@@ -0,0 +1,11 @@
+--- torture/config.mk.orig Mon Aug 28 23:34:14 2006
++++ torture/config.mk Mon Aug 28 23:34:27 2006
+@@ -198,7 +198,7 @@
+
+ #################################
+ # Start BINARY smbtorture
+-[BINARY::smbtorture]
++[BINARY::smbtorture4]
+ INSTALLDIR = BINDIR
+ PRIVATE_PROTO_HEADER = torture.h
+ OBJ_FILES = \
diff --git a/net/samba4wins/files/patch-utils_config.mk b/net/samba4wins/files/patch-utils_config.mk
index fedc67360658..b23040b8151e 100644
--- a/net/samba4wins/files/patch-utils_config.mk
+++ b/net/samba4wins/files/patch-utils_config.mk
@@ -1,5 +1,5 @@
---- utils/config.mk.orig Sun Apr 9 23:55:42 2006
-+++ utils/config.mk Sun Apr 9 23:56:16 2006
+--- utils/config.mk.orig Mon Jul 3 09:48:15 2006
++++ utils/config.mk Mon Aug 28 02:13:42 2006
@@ -77,7 +77,7 @@
#################################
@@ -9,3 +9,12 @@
INSTALLDIR = BINDIR
OBJ_FILES = \
nmblookup.o
+@@ -92,7 +92,7 @@
+
+ #################################
+ # Start BINARY testparm
+-[BINARY::testparm]
++[BINARY::testparm4]
+ INSTALLDIR = BINDIR
+ OBJ_FILES = \
+ testparm.o
diff --git a/net/samba4wins/files/smbd4wins.sh.in b/net/samba4wins/files/smbd4wins.in
index 095b756f7eb6..dd5f7a3423b7 100644
--- a/net/samba4wins/files/smbd4wins.sh.in
+++ b/net/samba4wins/files/smbd4wins.in
@@ -3,7 +3,7 @@
# $FreeBSD$
#
-# PROVIDE: smbd2wins
+# PROVIDE: smbd4wins
# REQUIRE: NETWORKING SERVERS named ldconfig
# BEFORE: DAEMON
# KEYWORD: shutdown
diff --git a/net/samba4wins/pkg-descr b/net/samba4wins/pkg-descr
index 2db57a1565f6..5591251fc195 100644
--- a/net/samba4wins/pkg-descr
+++ b/net/samba4wins/pkg-descr
@@ -1,6 +1,6 @@
The Samba4WINS project provides a full featured replicating WINS server
-for UNIX. It is a spinoff of the Samba 4 project, the upcoming version
-of the Samba software suite and will also be available as part of the
-Samba suite as soon as Samba 4 is released.
+for UNIX. It is a spinoff of the Samba4 project, the upcoming version of
+the Samba software suite and will also be available as part of the Samba
+suite as soon as Samba4 is released.
WWW: http://enterprisesamba.org/index.php?id=88
diff --git a/net/samba4wins/pkg-plist b/net/samba4wins/pkg-plist
index 8c87451aa3b0..a84f499dcf04 100644
--- a/net/samba4wins/pkg-plist
+++ b/net/samba4wins/pkg-plist
@@ -1,18 +1,17 @@
-@unexec %D/etc/rc.d/samba4wins.sh forcestop 2>/dev/null || true
etc/samba4wins.conf.sample
bin/nmblookup4
-bin/ldbadd
-bin/ldbdel
-bin/ldbedit
-bin/ldbmodify
-bin/ldbrename
-bin/ldbsearch
-bin/samba3dump
-bin/smbscript
-bin/smbstatus
-bin/smbtorture
-bin/testparm
-bin/winreg
+bin/ldbadd4
+bin/ldbdel4
+bin/ldbedit4
+bin/ldbmodify4
+bin/ldbrename4
+bin/ldbsearch4
+bin/samba3dump4
+bin/smbscript4
+bin/smbstatus4
+bin/smbtorture4
+bin/testparm4
+bin/winreg4
sbin/smbd4wins
lib/samba4wins/lowcase.dat
lib/samba4wins/upcase.dat
@@ -21,6 +20,7 @@ lib/samba4wins/valid.dat
%%PORTDOCS%%%%DOCSDIR%%/NEWS.txt
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%DATADIR%%/js/auth.js
%%DATADIR%%/js/base.js
%%DATADIR%%/js/encoder.js
@@ -40,12 +40,11 @@ lib/samba4wins/valid.dat
%%DATADIR%%/setup/provision_users.ldif
%%DATADIR%%/setup/schema.ldif
%%DATADIR%%/setup/secrets.ldif
-@dirrmtry lib/samba4wins/pkgconfig
-@dirrmtry private/tls
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/setup
@dirrm %%DATADIR%%/js
@dirrm %%DATADIR%%
+@dirrmtry lib/samba4wins/pkgconfig
@dirrm lib/samba4wins
@unexec echo "Warning: If you will *NOT* use this package anymore, please remove %%S4W_LOCKDIR%%/* manually."
@unexec echo "Warning: If you will *NOT* use this package anymore, please remove %%S4W_LOGDIR%%/* manually."
+@unexec %D/etc/rc.d/samba4wins.sh forcestop 2>/dev/null || true