aboutsummaryrefslogtreecommitdiff
path: root/net/samba
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-01-17 22:50:51 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-01-17 22:50:51 +0000
commit4b46071702fb4d6a6092bcea132d1605426564cb (patch)
treebc8b9a601d77d9321820876c4187851ed3ca18f4 /net/samba
parentd2b9fedd8b13277b27e4c9122f69a50a37472c2e (diff)
downloadports-4b46071702fb4d6a6092bcea132d1605426564cb.tar.gz
ports-4b46071702fb4d6a6092bcea132d1605426564cb.zip
Notes
Diffstat (limited to 'net/samba')
-rw-r--r--net/samba/Makefile13
-rw-r--r--net/samba/files/patch-ba47
-rw-r--r--net/samba/files/patch-include-includes.h14
3 files changed, 21 insertions, 53 deletions
diff --git a/net/samba/Makefile b/net/samba/Makefile
index 505f2a4b68ca..4471b3627e4f 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -7,7 +7,7 @@
PORTNAME= samba
PORTVERSION= 2.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= ftp://ftp.samba.org/pub/samba/%SUBDIR%/ \
ftp://samba.anu.edu.au/pub/samba/%SUBDIR%/ \
@@ -18,9 +18,7 @@ MASTER_SITE_SUBDIR= . old-versions old
MAINTAINER= dwcjr@FreeBSD.org
-.if defined(WITH_CUPS)
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
-.endif
.if defined(WITH_RECYCLE)
PATCH_SITES+= http://www.amherst.edu/~bbstone/recycle_bin/2.2.2/
@@ -46,15 +44,14 @@ CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
.include <bsd.port.pre.mk>
+# to find CUPS libs, includes
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
.endif
-.if defined(WITH_CUPS)
-# This enables CUPS printing support in Samba.
-CONFIGURE_ARGS+= --with-cups=${LOCALBASE}
-.endif
-
.if defined(WITH_ACL_SUPPORT)
.if ${OSVERSION} < 500018
BROKEN= "Requires a recent FreeBSD 5.0-CURRENT"
diff --git a/net/samba/files/patch-ba b/net/samba/files/patch-ba
index b6f5a757140d..c721da053dff 100644
--- a/net/samba/files/patch-ba
+++ b/net/samba/files/patch-ba
@@ -1,27 +1,5 @@
---- configure.in.orig Sat Oct 13 22:09:16 2001
-+++ configure.in Tue Oct 16 17:21:21 2001
-@@ -406,21 +406,6 @@
- AC_CHECK_TYPE(ssize_t, int)
- AC_CHECK_TYPE(wchar_t, unsigned short)
-
--############################################
--# for cups support we need libcups, and a handful of header files
--
--AC_CHECK_LIB(cups,httpConnect)
--
--# I wonder if there is a nicer way of doing this?
--
--if test x"$ac_cv_lib_cups_httpConnect" = x"yes"; then
-- AC_CHECK_HEADERS(cups/cups.h cups/language.h)
-- if test x"$ac_cv_header_cups_cups_h" = x"yes"; then
-- if test x"$ac_cv_header_cups_language_h" = x"yes"; then
-- AC_DEFINE(HAVE_CUPS)
-- fi
-- fi
--fi
-
- ############################################
- # we need libdl for PAM and the new VFS code
+--- configure.in.orig Sat Oct 13 17:09:16 2001
++++ configure.in Fri Jan 11 19:58:14 2002
@@ -1622,7 +1607,7 @@
yes)
AC_MSG_RESULT(yes)
@@ -31,24 +9,3 @@
CFLAGS="$CFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
;;
-@@ -1961,6 +1946,20 @@
- ;;
- esac ],
- AC_MSG_RESULT(no)
-+)
-+
-+#################################################
-+# check for CUPS printing support
-+AC_MSG_CHECKING(whether to use CUPS printing)
-+AC_ARG_WITH(cups,
-+[ --with-cups=base-dir Include CUPS printing support
-+ --without-cups Don't include CUPS printing support (default)],
-+[ AC_MSG_RESULT(yes)
-+ LIBS="$LIBS -lcups"
-+ CFLAGS="$CFLAGS -I$withval/include"
-+ LDFLAGS="$LDFLAGS -L$withval/lib"
-+ AC_CHECK_LIB(cups,httpConnect)],
-+ AC_MSG_RESULT(no)
- )
-
-
diff --git a/net/samba/files/patch-include-includes.h b/net/samba/files/patch-include-includes.h
new file mode 100644
index 000000000000..f426392920b2
--- /dev/null
+++ b/net/samba/files/patch-include-includes.h
@@ -0,0 +1,14 @@
+--- include/includes.h.orig Sat Oct 13 17:09:21 2001
++++ include/includes.h Fri Jan 11 22:12:06 2002
+@@ -27,6 +27,11 @@
+
+ #include "local.h"
+
++#ifdef __FreeBSD__
++#define DEFAULT_PRINTING PRINT_BSD
++#define PRINTCAP_NAME "/etc/printcap"
++#endif /* __FreeBSD__ */
++
+ #ifdef AIX
+ #define DEFAULT_PRINTING PRINT_AIX
+ #define PRINTCAP_NAME "/etc/qconfig"