aboutsummaryrefslogtreecommitdiff
path: root/net/samba
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-08-09 15:19:00 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-08-09 15:19:00 +0000
commit787d2de1cc9d95268c4fd15d88734146e87575f9 (patch)
tree4ec9f6b6033dcae1186c94c2bc22d63918e8b909 /net/samba
parent45924720fda4d30489e83722d947c5c8380613b1 (diff)
downloadports-787d2de1cc9d95268c4fd15d88734146e87575f9.tar.gz
ports-787d2de1cc9d95268c4fd15d88734146e87575f9.zip
Notes
Diffstat (limited to 'net/samba')
-rw-r--r--net/samba/Makefile15
-rw-r--r--net/samba/distinfo2
-rw-r--r--net/samba/files/patch-ba10
3 files changed, 17 insertions, 10 deletions
diff --git a/net/samba/Makefile b/net/samba/Makefile
index 3359d7289bfb..7234fbacd1d8 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -6,14 +6,16 @@
#
PORTNAME= samba
-PORTVERSION= 2.2.5
-PORTREVISION= 3
+PORTVERSION= 2.2.6.p1
CATEGORIES= net
-MASTER_SITES= http://us4.samba.org/samba/ftp/
+MASTER_SITES= http://us4.samba.org/samba/ftp/%SUBDIR%/
+MASTER_SITE_SUBDIR= pre old-versions .
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
MAINTAINER= dwcjr@FreeBSD.org
USE_BZIP2= YES
+USE_REINPLACE= YES
USE_SUBMAKE= YES
USE_GMAKE= YES
USE_LIBTOOL= YES
@@ -164,7 +166,12 @@ post-build:
.endif
pre-configure:
- ${PERL} -pi.fbsd -e 's/DYNEXP="-Wl,-Bdynamic"/DYNEXP="-Wl,--export-dynamic"/' ${WRKSRC}/configure.in
+ ${REINPLACE_CMD} -e 's/DYNEXP="-Wl,-Bdynamic"/DYNEXP="-Wl,--export-dynamic"/' ${WRKSRC}/configure.in
+
+pre-build:
+ ${RM} -fr ${WRKSRC}/include/proto.h
+ (cd ${WRKSRC} && make proto)
+
post-install:
.if defined(WITH_AUDIT) || defined(WITH_RECYCLE)
@test -d ${SAMBA_VFSDIR} || ${MKDIR} ${SAMBA_VFSDIR}
diff --git a/net/samba/distinfo b/net/samba/distinfo
index 290cadece519..dbab634d4e27 100644
--- a/net/samba/distinfo
+++ b/net/samba/distinfo
@@ -1 +1 @@
-MD5 (samba-2.2.5.tar.bz2) = 0239d9302ed3223ff5e98dd3235a2336
+MD5 (samba-2.2.6pre1.tar.bz2) = b3999e68503f7f77bca1de3958c472ae
diff --git a/net/samba/files/patch-ba b/net/samba/files/patch-ba
index 02e57e15c31c..de7927b3c230 100644
--- a/net/samba/files/patch-ba
+++ b/net/samba/files/patch-ba
@@ -1,5 +1,5 @@
---- source/configure.in.orig Sat Jun 8 07:55:55 2002
-+++ source/configure.in Mon Jun 17 18:15:30 2002
+--- source/configure.in.orig Fri Aug 9 08:52:09 2002
++++ source/configure.in Fri Aug 9 08:53:11 2002
@@ -884,7 +884,7 @@
LDSHFLAGS="-shared"
DYNEXP="-Wl,-Bdynamic"
@@ -20,10 +20,10 @@
;;
@@ -2073,7 +2073,7 @@
AC_DEFINE(WITH_LDAP_SAM)
- LIBS="-lldap $LDAPLIBS"
+ LDAPLIBS="-lldap"
AC_CHECK_LIB(lber, ber_bvfree, [LDAPLIBS="$LDAPLIBS -llber"])
- LDAPLIBS="-lresolv $LDAPLIBS"
+ LDAPLIBS="$LDAPLIBS"
+ old_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS $LDAPLIBS"
AC_CHECK_FUNCS(ldap_start_tls_s)
- with_smbpasswd_sam=no
- ;;