aboutsummaryrefslogtreecommitdiff
path: root/net/samba
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-07-11 13:32:55 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-07-11 13:32:55 +0000
commit0e8580ecbae0b412dbea44795c72fbb0947e4a44 (patch)
treeba821c7e230ed1c3d7213946816e4b0c3823d706 /net/samba
parent58e6d89001ee68b85b6a466ab52b01e7bf16206b (diff)
Notes
Diffstat (limited to 'net/samba')
-rw-r--r--net/samba/Makefile8
-rw-r--r--net/samba/scripts/configure.samba10
2 files changed, 17 insertions, 1 deletions
diff --git a/net/samba/Makefile b/net/samba/Makefile
index 2038fdb07ee9..234635e895b7 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -105,6 +105,14 @@ CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
WITH_CUPS= yes
.endif
+.if defined(WITH_WINBIND)
+CONFIGURE_ARGS+= --with-winbind
+.endif
+
+.if defined(WITH_WINBIND_AUTH_CHALLENGE)
+CONFIGURE_ARGS+= --with-winbind-auth-challenge
+.endif
+
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.samba
diff --git a/net/samba/scripts/configure.samba b/net/samba/scripts/configure.samba
index aa87e73feea2..80af4c823d43 100644
--- a/net/samba/scripts/configure.samba
+++ b/net/samba/scripts/configure.samba
@@ -13,7 +13,7 @@ if [ "${BATCH}" ]; then
else
/usr/bin/dialog --title "configuration options" --clear \
--checklist "\n\
-Please select desired options:" -1 -1 10 \
+Please select desired options:" -1 -1 12 \
syslog "With syslog support" OFF \
ssl "With ssl support" OFF \
ldap "With LDAP2 support" OFF \
@@ -24,6 +24,8 @@ msdfs "With MSDFS support" OFF \
quota "With Quota support" OFF \
recycle "With Recycle Bin" OFF \
audit "With Audit" OFF \
+winbind "With Winbind" OFF \
+wbauth "With Winbind Auth Challenge" OFF \
2> $tempfile
retval=$?
@@ -79,6 +81,12 @@ while [ "$1" ]; do
\"audit\")
echo "WITH_AUDIT=YES" >>${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
;;
+ \"winbind\")
+ echo "WITH_WINBIND=YES" >>${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ ;;
+ \"wbauth\")
+ echo "WITH_WINBIND_AUTH_CHALLENGE=YES" >>${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ ;;
*)
echo "Invalid option: $1"
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc